Input Lag

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of dankcushions dankcushions 12 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #122403
    Profile photo of jrburke99
    jrburke99
    Participant

    I am using the latest RetroPie 3.6 on a new Raspberry Pi 3, and HDMI output. I have tried writing a fresh RetroPie image to a Class 10 16GB card, and loading ONLY Super Mario Bros. 3 onto it. There is a noticeable lag between button presses and response on-screen. I have tried my USB controller on my PC running Nestopia and the same ROM, and the response is snappy, just as if playing on an actual NES console. I have tried plugging my Pi into 2 of my TVs, setting those to “Game” mode, and even tried the Pi on my PC monitor. The laggy response feels exactly the same on all displays and modes.

    Is there some setting I can use to improve this? Should I be setting the memory split (I do not bother, as none of the documentation seems to indicate that being necessary), or making other adjustments in order to better sync the display? Thank you!

    #122404
    Profile photo of jrburke99
    jrburke99
    Participant

    I have thought about maybe using the RCA composite output instead on the same TVs. One of my TVs is LCD, the other is DLP. Might I avoid the lag this way?

    #122424
    Profile photo of dankcushions
    dankcushions
    Participant

    memory split has nothing to do with it (or anything much to do with retropie, as the documentation says).

    surely if you’ve tested your pi on your pc monitor, then you’ve ruled out the tv/display as your issue?

    please look at this thread for all information on this subject: http://blog.petrockblock.com/forums/topic/hows-your-input-lag/

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar