Input Lag on SNES libretro core

Home Forums RetroPie Project Everything else related to the RetroPie Project Input Lag on SNES libretro core

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 4 voices, and was last updated by Profile photo of taalas taalas 2 years ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #95855
    Profile photo of taalas
    taalas
    Participant

    Hi,

    I know this has been a topic in the past but I still am struggling with this: for all libretro cores that I tried for SNES I get noticable input lag when playing games. I have already:

    – tried different gamepads
    – made sure that it is not my TV (other systems have no or much less input lag)
    – tried different combinations of forcing integer scaling and hard GPU sync

    Does anyone have a non-lagging SNES emulation and can give me some tips?

    #95858
    Profile photo of gizmo98
    gizmo98
    Participant

    Disable threaded video.

    #95859
    Profile photo of taalas
    taalas
    Participant

    Will try that, thanks gizmo98

    #95862
    Profile photo of kitchuk
    kitchuk
    Participant

    Will try that, thanks gizmo98

    Are you using a Samsung Smart TV? f so, select the inputs and remain the Pi’s HDMI source to PC. This should also improve any input lag you have. To be honest this would work with most TV’s. If there inst a PC mode look for a Game Mode.

    #95866
    Profile photo of taalas
    taalas
    Participant

    Hi kitchuk,

    thanks for your answer. Not to sound harsh but as I said I have made sure, that it is not my TV producing the lag. Other cores and Limelight in particular show no (noticable) input lag at all.

    #95867
    Profile photo of kitchuk
    kitchuk
    Participant

    Hi kitchuk,

    thanks for your answer. Not to sound harsh but as I said I have made sure, that it is not my TV producing the lag. Other cores and Limelight in particular show no (noticable) input lag at all.

    No problem, but I just thought I’d be sure you knew.

    #95882
    Profile photo of sdbrook
    sdbrook
    Participant

    I’ve heard this may help:

    Open opt/retropie/configs/all/retroarch.cfg
    set “video_hard_sync = true” and make sure it is not commented out.

    #95888
    Profile photo of taalas
    taalas
    Participant

    Hi sdbrook,

    thanks for your suggestion. As I stated in the original post I had already tried that though…

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar