Input Lag Correction Settings

Home Forums RetroPie Project Controller Configuration in RetroPie Input Lag Correction Settings

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of buzz buzz 1 year, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #112606
    Profile photo of sjo102784
    sjo102784
    Participant

    For those of you who use emulators on your Rpi and experience input lag from controllers, I think Ive found the best settings to eliminate input lag. Compared to the actual consoles, these settings virtually eliminated input lag on a Logitech dual shock, SNES replica, and NES replica.

    -Raspberry Pi overclock set to 800mhz
    -Edit the retroarch.cfg file found at /opt/retropie/configs/all and change:
    vsync =True
    video_hard_sync = True
    video_frame_delay = 10

    Those small changes allowed me to have virtually input lag free gaming on all emulators. Your settings may need additional tuning depending on the response time/model of your TV (mine is a Samsung LCD with Game Mode which goes to a lower response time for gaming) so you may want to play with the settings a bit if these arent perfect.

    It also may be worth noting that Im using a Raspberry Pi 2. Older models may not respond the same. I found under or overclocking beyond 800mhz threw all video settings off completely and made input lag worse. Id try these settings as a starting point and tweak if necessary.

    Just wanted to share, it took a lot of testing to get everything dialed in so Im hoping I can save someone a buttload of time.

    #112607
    Profile photo of buzz
    buzz
    Keymaster

    Just to note : Video hard sync is not used on the RPI.

    #112608
    Profile photo of buzz
    buzz
    Keymaster

    Do you mean video_vsync for the first option btw – that should be enabled by default.

    Setting “video_threaded = false” can also help with latency (at the cost of performance)

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar