Immediate crash upon save state load or save in lr-beetle-vb

Home Forums RetroPie Project Everything else related to the RetroPie Project Immediate crash upon save state load or save in lr-beetle-vb

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of DavidBowman DavidBowman 1 year, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #122231
    Profile photo of DavidBowman
    DavidBowman
    Participant

    Hey everyone,

    My apologies if this has been covered before. I looked, but didn’t see this problem.

    I’m using a Raspberry Pi 3 and RetroPie 3.6 – imaged fresh / no upgrades from old versions. I installed the Virtual Boy emulator from the experimental packages (lr-beetle-vb) and it plays pretty great!

    Save files (the normal in-game ones) work fine, but any time I attempt to load or save a state file, it immediately crashes. The save state file is actually created though. I can see it from ssh or through a card reader.

    I’ve experimented with changing the hot keys with basically no success. It seems the biggest difference I can force is to get the emulator to just go black screen and hang rather than crash back to EmulationStation.

    Does anyone have any suggestions on how to fix this?

    Thanks in advance!

    Dave

    #122234
    Profile photo of herbfargus
    herbfargus
    Moderator

    upstream bug.

    add
    rewind_enable = "false"
    to your system specific config

    https://github.com/RetroPie/RetroPie-Setup/issues/1266

    #122252
    Profile photo of DavidBowman
    DavidBowman
    Participant

    Thank you for the reply, Herb. I appreciate your ongoing support of the project.

    I should have mentioned that I tried that already. Unfortunately that doesn’t want to work for me. I tried that setting two ways (with and without quotes):

    rewind_enable = "false"

    and

    rewind_enable = false

    Both of those above the #include line. I also verified it was set through the Retroarch menu as well. Rebooted, no change.

    It hangs on a black screen until I exit back to EmulationStation.

    Did I miss something simple somewhere?

    Thanks again.

    • This reply was modified 1 year, 1 month ago by Profile photo of DavidBowman DavidBowman.
    #122256
    Profile photo of herbfargus
    herbfargus
    Moderator

    Did you also change the system folder to the virtualboy rom folder? It might need that too possibly. It worked when I tested it a while ago but it’s possible things may have changed since then. Note that it is in Experimental for a reason 😉 and until upstream is sorted there’s not much we can do to fix it.

    #122257
    Profile photo of DavidBowman
    DavidBowman
    Participant

    I did do that as well. I saw your replies on that bug report, so I figured maybe someone may know if I missed something simple. I guess not.

    That’s not really a problem, and I definitely understand the beta nature of some of these emulators. Thanks for your help.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar