Image won't boot: Repeated Kernel Errors

Home Forums RetroPie Project Everything else related to the RetroPie Project Image won't boot: Repeated Kernel Errors

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , , ,

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of ariotofmyown ariotofmyown 2 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #89129
    Profile photo of ariotofmyown
    ariotofmyown
    Participant

    Retropie 2.6 won’t boot on my new RBpi2.

    I bought a new RBPi2 kit which included an 8GB SD card pre-loaded with NOOBS. Since I only want to run retropie on this machine, I deleted NOOBS from the card, quick & overwrite formatted the entire SD card and downloaded the latest version of retropie 2.6 version 2.

    I extracted the img file and tried flashing the image to the card using rpi SD-card builder (I’m running Yosemite) but the process failed repeatedly so I used Apple PiBaker instead and the flash was successful.

    I inserted the SD card into the Pi and it would not boot. Instead, I received a kernel error (179,2). After reading through the forums, it was suggested that I edit the cmdline.txt file from blk2 to blk6, as seen here. I was told holding shift during the startup process would take me to recovery mode where I could edit the file, but that did not work (even with a powered USB hub). So I pulled the SD card, put it back into my mac and edited the cmdline.txt in the boot partition of the SD card directly on my laptop. I saved the file and put it back into the Pi for startup. This time I received a similar error, but it was (179,6) instead of (179,2). So obviously, pointing to both blk2 and/or blk6 causes the boot process to fail.

    Moreover, I noticed that there was additional code located in my cmdline.txt file than was seen in the edit solution I linked above. My cmdline.txt includes extra “console” text as seen here: dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p6 rootfstype=ext4 elevator=deadline rootwait.

    I’ve overwritten, cleared and re-flashed the SD card numerous times with no luck. I’ve tried editing the cmdline.txt to blk1, blk2, and blk6 with no luck. I’ve re-downloaded and re-extracted the retropie 2.6v2 to ensure it wasn’t a corrupt file, but both copies have failed.

    I’m not sure what the problem is here, but I can’t get the Pi to do anything at this point. Should I try running raspbian or noobs on the pi to see if that works? I really just want to set this up for a retropie gaming station, so hopefully someone here can suggest a fix.

    Thanks in advance.

    • This topic was modified 2 years, 1 month ago by Profile photo of ariotofmyown ariotofmyown.

    #89141
    Profile photo of buzz
    buzz
    Keymaster

    I suspect the image was somehow not written correctly or there is something wrong with the sdcard. Perhaps try another card, and try something like win32 imager to write it ?

    https://supernintendopi.wordpress.com/2013/01/23/an-a-to-z-beginners-guide-to-installing-retropie-on-a-raspberry-pi/

    You could also try raspbian to see if that works for you (retropie is based on raspbian)

    #90133
    Profile photo of ariotofmyown
    ariotofmyown
    Participant

    RESOLVED: The issue was actually with the SD card all along. The card I used was apparently sufficient to flash and boot NOOBS, but not retropie or raspbian. I purchased a new Sandisk Class 10 Ultra SD card, repeated the process and the image flashed successfully/booted immediately when I placed it in the RB Pi.

    The card in question was made by LG and came included with a RB Pi kit from tinkersphere.com

    So the takeaway here is do not use the type of LG SD card (above) for Raspbian or Retropie projects, only NOOBS.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar