How to install new themes

Home Forums RetroPie Project Emulation Station Themes How to install new themes

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 11 replies, has 7 voices, and was last updated by Profile photo of gonzothegreat gonzothegreat 1 year ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #107517
    Profile photo of herbfargus
    herbfargus
    Moderator

    Most themes that are mostly complete can be installed from the setup script under option 3.

    Then you can switch to the newly installed theme with the start menu in emulationstation under uisettings.

    You may need to press f4 or quit in order to refresh the new theme.

    See the wiki page here for more information as well as a gallery of the theme options:

    https://github.com/RetroPie/RetroPie-Setup/wiki/themes

    #111676
    Profile photo of AmadhiX
    AmadhiX
    Participant

    If your theme of choice isn’t in the installer yet, you’ll need to install it manually. I wrote up a set of instructions in another thread, so I figured I’d put them here for reference. Hope that’s ok?

    This is a little more advanced. If you have the option, the installer is probably the way to go. If not, read on.

    In short, you’ll need to download the theme, extract the files, and copy the contents into the themes folder on the Pi.

    1. From a desktop, download and extract your theme. Usually, this will come as a zip file.
    2. Connect to the Pi using SCP. I use the program WinSCP for this.
    3. Copy the theme folder you extracted into the /home/pi/.emulationstation/themes folder. You may need to create the folder if it doesn’t exist already.
    4. In EmulationStation, press Start, select UI Settings, then select the Theme Set you installed.
    5. Select Back and the new theme should load.
    • This reply was modified 1 year, 4 months ago by Profile photo of AmadhiX AmadhiX. Reason: Updated theme location and removed nonsense about file permissions. Thanks buzz!
    #111679
    Profile photo of buzz
    buzz
    Keymaster

    you should use /home/pi/.emulationstation/themes and not mess with /etc/emulationstation permissions etc – also 777 is never a good idea, as it makes it writable to any user, and is the wrong permissions for files (sets the executable bit).

    • This reply was modified 1 year, 4 months ago by Profile photo of buzz buzz.
    #111681
    Profile photo of AmadhiX
    AmadhiX
    Participant

    I didn’t even realize /home/pi/.emulationstation/themes/ was an option, as it didn’t exist on my system, but that’s even better. I’ll edit my post.

    It’s a little weird to have multiple locations for them, but I’m assuming the installer dumps them into /etc/emulationstation/ so it can handle updates/uninstalls without worrying about user interference.

    #111685
    Profile photo of buzz
    buzz
    Keymaster

    Yep. for example if you want a custom es_systems.cfg you can create one in ~/.emulationstation and it will be used over the retropie one. You will of course then have to manually update it if there are changes to the way things are launched etc.

    • This reply was modified 1 year, 4 months ago by Profile photo of buzz buzz.
    #111686
    Profile photo of AmadhiX
    AmadhiX
    Participant

    Agh, that’s cool! Somehow I completely missed this functionality, but it will definitely simplify any future customizations / theme development. Thanks!

    #112230
    Profile photo of goto
    goto
    Participant

    I have a doubt/problem about themes installation, dont know if im doing it wrong or what happened, the problem is, when I install a new theme from the menu I lost the screen options, all of it, im not able to see any menu or option, section, etc.., If I try to access to any emulator (I can access to the Amiga emulator when the system boot, because is the first emulator that I know is there and I just need to go forward) when I go out sometimes i can see something, but is far from stable
    At first i was thinking that maybe is a problem with the roms, something like 10000, or because I have the roms in a NAS, but now I try it from a fresh installation, and same issue with all the themes.
    Raspberry Pi 2
    Greetings

    #112266
    Profile photo of herbfargus
    herbfargus
    Moderator

    Limitation of emulationstation. If you are a rom hoarder the only themes that will work for you are carbon, turtle, and maybe eudora. The rest will always result in a white screen of death.

    #112376
    Profile photo of goto
    goto
    Participant

    Thanks for the reply herbfargus
    Is there any place to check the limitations of the system? (I search for it but I did not found anithyng :/ )
    Now I see, with the new 3.3 versión, that have the same problem but this time with the original theme (trying the same configuration with the 3.2.1 it Works without problem)

    #121115
    Profile photo of flairs
    flairs
    Participant

    Hey, this is my first time doing this, asking a question and all. but something has really been bothering me with putting in an external theme. I use WinSCP and what i am trying to do is add a custom theme. i made a folder in my /home/pi/.emulationstation/ called themes. I put the theme pack into the themes folder and yes it does come up when i go to UI then change the theme but no pictures come out it is just all white with plain text. can someone help me or point me in the right direction of what i may be doing wrong and how i may be able to fix this frustrating problem?

    #121435
    Profile photo of karimi
    karimi
    Participant

    Make a restart
    When this doesn’t help switch to another ttheme restart again and try it again…I got this problem all the time. Sometimes just during browsing the games…

    #121437
    Profile photo of gonzothegreat
    gonzothegreat
    Participant

    just restart emulation station via the quit menu

Viewing 12 posts - 1 through 12 (of 12 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar