How to Auto Mount sda1?

Home Forums RetroPie Project New to RetroPie? Start Here! How to Auto Mount sda1?

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.


This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of xd3l xd3l 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #106875
    Profile photo of xd3l

    I have a few drives that are 4Tb in size that I store my media on.
    Since I installed Kodi inside of RetroPi, I’d really like to be able to access these. Ironically enough they do not show up under USB.

    What I have to do is “sudo mount /dev/sda1 /mnt”

    I’d rather not have to go into the command line every time I want to access the drive in Kodi, what can I do to make RetroPie auto detect the drive like OpenElec Kodi distro does?

    Profile photo of xd3l

    I am trying to follow this guide:

    replacing “udevinfo -a -p /sys/block/sdc/ | grep model” with “udevadm info -a -n /dev/sda1”

    I get down to:

    # /etc/init.d/udev restart
    Stopping the hotplug events dispatcher: udevd.
    Starting the hotplug events dispatcher: udevd.

    Plug in external USB and your new base name is:

    ls -l /dev/Iomega*
    lrwxrwxrwx 1 root root 3 2011-02-23 12:36 /dev/Iomega -> sdc
    lrwxrwxrwx 1 root root 12 2011-02-23 12:36 /dev/Iomega0 -> bsg/14:0:0:0
    lrwxrwxrwx 1 root root 4 2011-02-23 12:36 /dev/Iomega1 -> sdc1
    lrwxrwxrwx 1 root root 3 2011-02-23 12:36 /dev/Iomega3 -> sg3

    Please note that /dev/Iomega1 points to a /dev/sdc1, which is exactly the partition we are interested in and we use it next to configure autofs.


    And I do not have the custom directory in /dev/

    As a work around I updated to script to read:

    sudo mount /dev/sda1 /mnt && kodi

    Though I’d prefer if ALL of my drives auto mounted.

    Profile photo of Billy T. Pilgrim
    Billy T. Pilgrim

    I use two USB sticks to store my PC and Playstation games, and for the RetroPie setup I have I need them to always mount to the same points. I’m not sure if this works for USB hard drives too or if it’s just applicable to flash sticks, so bear that in mind. First I found out the uuid of the drive using:

    sudo blkid

    Then I edited etc/fstab to add a new entry. It should take the following form:

    [Device] [Mount Point] [File_system] [Options] [dump] [fsck order]

    So mine looked something like:

    uuid=F03A-33EB /media/usb0 vfat defaults 0 0

    I can’t remember exactly what I put for the options, I know I needed to alter something to get it readable and writeable – I’m away from the Pi at the moment, I’ll look it up when I get home. (the UUID is just made up there, yours will be different).

    That should always mount that specific drive to /media/usb0 on boot. Again, I don’t know if it’s the same for hard drives, but my USB sticks get a new uuid every time they’re formatted.

    Hope that’s helpful!

    Profile photo of xd3l

    Yes, you are right, I forgot all about Fastab, it has been years!

    Since I started this post, I found out that since I am over clocking my Pi 2, that I increase the chances of burning out my SD card, so I opted to only initiate the boot sequence from SD, and now host my OS on my USB stick, which of course in itself also solves this problem without the need to edit Fstab.

    Thank you though, maybe this will come in handy for those who don’t share my SD phobias, or just that little extra speed boot, save money, or what have you.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar