How can I save my settings?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 1 year, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #102795
    Profile photo of narp
    narp
    Participant

    I’ve enabled per core config and save on exit, and it created a file called libretro.cfg. Well, thats good and all, but any time I exit and then go to play the game again, it has those options disabled and libretro.cfg is not loaded; instead retroarch.cfg is loaded. I can manually go select libretro.cfg and everything is good, but thats a pain to do every time and also it doesnt have certain things like hotkeys enabled. Using RP3 RC1. Thanks!

    #102797
    Profile photo of Floob
    Floob
    Moderator

    This partly answers why that happens:
    http://blog.petrockblock.com/forums/topic/cant-save-settings-on-snes9x-next-and-psx/#post-102732

    The short answer to that is rip out the changes you need and manually add them into the retroarch.cfg, it should take about 5 mins when you get the hang of it, and you only have to do it once.
    I’ll try to do a specific video for that. In the meantime, check this one:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #102844
    Profile photo of narp
    narp
    Participant

    Oh cool, thanks floob! Just to be sure, I make the changes to the retroarch.cfg of the specific emulator I want, not the main config, right? It seems stupid, but I feel like everything I do has an unintended consequence haha.

    Another question: i’ve enabled video_smooth=true in the main retroarch.cfg. However, some emulators, like snes, have video_smooth=false in their retroarch.cfg. If I understand correctly, this overrides the main config file. Why would those be in there if I’ve never set them to be? This is what my retroarch.cfg looks like:

    # Smoothens picture with bilinear filtering. Should be disabled if using pixel shaders.
    video_smooth = true

    I set it to what I want (true from false) and then delete the #, right? I ask because some things in the config have no # and some do, and some have the # then nothing after =, etc. Just kinda confusing. Sorry for all the quetions!

    • This reply was modified 1 year, 9 months ago by Profile photo of narp narp.
    #102852
    Profile photo of Floob
    Floob
    Moderator

    Yes, make them in the specific system version of retroarch.cfg, like /opt/retropie/configs/megadrive/retroarch.cfg
    And make the change at the top of the file, before the #include line.
    If you add it after, it wont override the one in /all/retroarch.cfg

    Lines with a hash, # are just comments, they can stay if you like as they are ignored. Just dont take out the #include line as that isnt a comment.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar