[SOLVED] Hotkeys configuration : Switch the shaders ingame (Retropie v.3b4)

Home Forums RetroPie Project Controller Configuration in RetroPie [SOLVED] Hotkeys configuration : Switch the shaders ingame (Retropie v.3b4)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: ,

This topic contains 15 replies, has 5 voices, and was last updated by Profile photo of mydriaze mydriaze 1 year, 1 month ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #101809
    Profile photo of kommissar
    kommissar
    Participant

    Hi everyone,

    After digging the net for weeks, i didn’t find the answer to my issue.
    I can’t set the hotkeys for switching the shaders ingame (previous/next shaders) in Retropie v.3b4 (rpi2).
    I successfully set these hotkeys in the Retropie v.3 (rpi1) and v.2.6 (rpi1).
    I just bought a Raspberry Pi 2, so i wanted to put the correct system version on my new Pi.

    This is my current config for my controller (iBuffalo Snes controller) :

    
    # ======================================================================
    # Config : iBuffalo SNES Classic Gamepad : Par défaut
    # ======================================================================
    input_a_btn = "0"
    input_b_btn = "1"
    input_x_btn = "2"
    input_y_btn = "3"
    input_start_btn = "7"
    input_select_btn = "6"
    input_l_btn = "4"
    input_r_btn = "5"
    input_up_axis = "-1"
    input_down_axis = "+1"
    input_left_axis = "-0"
    input_right_axis = "+0"
    
    # ======================================================================
    # Config : iBuffalo SNES Classic Gamepad : Hotkeys
    # [Select] + [Start]      : Leave the game
    # [Select] + [R]          : Save state
    # [Select] + [L]          : Load state
    # [Select] +           : Reset
    # [Select] + [DPad-LEFT]  : Previous shader
    # [Select] + [DPad-RIGHT] : Next shader
    # [Select] + [DPad-DOWN]  : Decrease state slot
    # [Select] + [DPad-UP]    : Increase state slot
    # ======================================================================
    input_enable_hotkey_btn = "6"
    input_exit_emulator_btn = "7"
    input_save_state_btn = "5"
    input_load_state_btn = "4"
    input_reset_btn = "1"
    input_shader_prev_axis = "-0"
    input_shader_next_axis = "+0"
    input_state_slot_increase_axis = "-1"
    input_state_slot_decrease_axis = "+1"
    

    This config works for the rpi1 version, but not the rpi2.
    I also tried with the “btn” version of the hotkey on Y and X (input_shader_prev_btn). Same result. :/
    Did i miss something ?

    PS : Sorry for my english. It’s not my native language. ^^

    EDIT : 2015-07-14

    Solution : Update RetroArch
    In emulationstation : go to Retropie > RETROPIE-SETUP
    Then : choose “5 Install individual emulators from binaries or source”
    Find retroarch > binary
    Reboot
    And it works 😀

    Big thanks to buzz for the solution !!!

    • This topic was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    • This topic was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    • This topic was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.

    #101817
    Profile photo of Floob
    Floob
    Moderator

    I know you’ve said you are using version 3 beta 4, but can you confirm the full path of the file you are showing above?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101819
    Profile photo of kommissar
    kommissar
    Participant

    Of course. It’s the controller configuration file located here :
    /opt/retropie/configs/all/retroarch-joypads/USB,2-axis8-buttongamepad.cfg

    I forgot to precise : when i use the hotkey (SELECT + “left” or “right”), i leave the emulator. Unfortunately, i don’t see any log error message on the screen.

    #101820
    Profile photo of Floob
    Floob
    Moderator

    Can you put on pastebin.com your file
    /opt/retropie/configs/all/retroarch.cfg?

    Also, I’m presuming you havent altered any system specific retroarch.cfg files.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101830
    Profile photo of kommissar
    kommissar
    Participant

    Here, the link to the files :
    /opt/retropie/configs/all/retroarch-joypads/USB,2-axis8-buttongamepad.cfg

    /opt/retropie/configs/all/retroarch.cfg

    I didn’t change anything in the /all/retroarch.cfg. But in /mastersystem/retroarch.cfg, i just did these changes :

    
    #video_shader = /opt/retropie/emulators/retroarch/shader/phosphor.glslp
    video_shader_enable = true
    

    I enable the shaders changes and comment the default used shader.

    EDIT : After a purge of /tmp : I got a log !!!

    
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 671:  3983 Segmentation fault      /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/mastersystem/retroarch.cfg "/home/pi/RetroPie/roms/mastersystem/Mortal Kombat (UE) [!].sms" --appendconfig /tmp/retroarch.cfg
    

    It seems something wrong occurred during the command execution. I checked all the paths used in the command are correct / exists. (with ls -al <path>)

    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    #101832
    Profile photo of Floob
    Floob
    Moderator

    Try changing
    input_enable_hotkey = nul
    to
    input_enable_hotkey = alt

    in your
    /opt/retropie/configs/all/retroarch.cfg

    Then in game, hold “select” and check “m” and “n” work to change shader.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101833
    Profile photo of kommissar
    kommissar
    Participant

    I tried it. The behavior is the same : exit to emulationstation.
    Same error in the log too : runcommand.sh line 671: 3034 Segmentation fault
    :/

    #101847
    Profile photo of Floob
    Floob
    Moderator

    Can you try from a clean retropie 3 beta 4, then just add
    input_shader_prev_axis = “-0”
    input_shader_next_axis = “+0”

    to the controller file it generates?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101856
    Profile photo of kommissar
    kommissar
    Participant

    Well, i just tried on a fresh install of Retropie v.3b4 and … the behavior is the same : runcommand.sh line 671: 3034 Segmentation fault.
    The steps i did for this install :
    * Write the image on SD card
    * Detect my pad with emulationstation (/opt/retropie/configs/all/retroarch-joypads/USB,2-axis_8-button_gamepad__.cfg generated)
    * Add “Alex kidd in Miracle World” (all my childhood :D) in mastersystem roms directory.
    * Edit the retroarch.cfg in mastersystem in order to enable shaders (with and without the 1st line):

    
    video_shader = /opt/retropie/emulators/retroarch/shader/phosphor.glslp
    video_shader_enable = true
    

    * Edit USB,2-axis_8-button_gamepad__.cfg : i tested 2 configs :

    
    /* other buttons... */
    input_shader_prev_axis = "-1"
    input_shader_next_axis = "+1"
    input_enable_hotkey_btn = "6"
    

    and

    
    /* other buttons... */
    input_enable_hotkey_btn = "6"
    input_shader_prev_axis = "-1"
    input_shader_next_axis = "+1"
    

    I swapped +/-0 and +/-1, same result on the respective shader assign button.

    The complete log file : /tmp/runcommand.log

    
    RetroArch: rarch_log_libretro: [libretro INFO] :: detected SMS ROM
    
    RetroArch [WARN] :: resolve_extensions :: [GL]: GLES implementation does not have BGRA8888 extension.
    32-bit path will require conversion.
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 671:  4442 Segmentation fault      /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/mastersystem/retroarch.cfg "/home/pi/RetroPie/roms/mastersystem/Alex Kidd in Miracle World (UE) [!].sms" --appendconfig /tmp/retroarch.cfg
    
    
    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    #101941
    Profile photo of Floob
    Floob
    Moderator

    I just gave this a go and I get the same results.
    Its fine in RetroPie 3 beta 2.

    My log file was

    RetroArch: rarch_log_libretro: [libretro INFO] :: Frontend supports RGB565 - will use that instead of XRGB1555.
    RetroArch: rarch_log_libretro: [libretro INFO] :: Loading /home/pi/RetroPie/roms/nes/Castlevania (Europe).nes...
    
    RetroArch: rarch_log_libretro: [libretro INFO] ::  PRG ROM:    8 x 16KiB
    RetroArch: rarch_log_libretro: [libretro INFO] ::  CHR ROM:    0 x  8KiB
    RetroArch: rarch_log_libretro: [libretro INFO] ::  ROM CRC32:  0xa93527e2
    RetroArch: rarch_log_libretro: [libretro INFO] ::  ROM MD5:  0xab930e91eb9bb51e8acbf7bf2187f369
    RetroArch: rarch_log_libretro: [libretro INFO] ::  Mapper #:  2
    RetroArch: rarch_log_libretro: [libretro INFO] ::  Mapper name: UNROM
    RetroArch: rarch_log_libretro: [libretro INFO] ::  Mirroring: Vertical
    RetroArch: rarch_log_libretro: [libretro INFO] ::  Battery-backed: No
    RetroArch: rarch_log_libretro: [libretro INFO] ::  Trained: No
    RetroArch: rarch_log_libretro: [libretro INFO] ::
    RetroArch [WARN] :: resolve_extensions :: [GL]: GLES implementation does not have BGRA8888 extension.
    32-bit path will require conversion.
    RetroArch [WARN] :: gl_glsl_init :: [GL]: Stock GLSL shaders will be used.
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 671:  3047 Segmentation fault      /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-fceumm/fceumm_libretro.so --config /opt/retropie/configs/nes/retroarch.cfg "/home/pi/RetroPie/roms/nes/Castlevania (Europe).nes" --appendconfig /tmp/retroarch.cfg

    I’ll raise an issue on Github.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101945
    Profile photo of kommissar
    kommissar
    Participant

    Ok, thanks to confirm that it was a bug. I started to being mad by installing again & again images on SD, checking all the config files in order to find my mistake.
    You saved my mental health. 😀

    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    #102031
    Profile photo of buzz
    buzz
    Keymaster

    update retroarch from binary via menu 5 in retropie-setup. there are multiple retroarch bugs in the last image which have been solved since.

    #102034
    Profile photo of kommissar
    kommissar
    Participant

    Thanks !!!! It works perfectly now !!!!

    #115696
    Profile photo of nemo1966
    nemo1966
    Participant

    Hi guys – pretty new to RetroArch/Pie. Struggling with a few things and this is one of them! Latest version of RetroPie from the site.

    My /opt/retropie/configs/all/retroarch-joypads/

    input_device = "raphnet.net (S)NES/Atari_USB"
    input_driver = "udev"
    input_l2_btn = "6"
    input_start_btn = "3"
    input_exit_emulator_btn = "3"
    input_up_axis = "-1"
    input_a_btn = "4"
    input_b_btn = "0"
    input_reset_btn = "0"
    input_down_axis = "+1"
    input_r2_btn = "7"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_x_btn = "5"
    input_menu_toggle_btn = "5"
    input_select_btn = "2"
    input_enable_hotkey_btn = "2"
    input_y_btn = "1"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"
    
    # ======================================================================
    # Config : raphnet.net (S)NES/Atari_USB : Hotkeys
    # [Select] + [Start]      : Leave the game
    # [Select] + [R]          : Save state
    # [Select] + [L]          : Load state
    # [Select] +           : Reset
    # [Select] + [DPad-DOWN]  : Previous shader
    # [Select] + [DPad-UP] : Next shader
    # [Select] + [DPad-LEFT]  : Decrease state slot
    # [Select] + [DPad-RIGHT]    : Increase state slot
    # ======================================================================
    
    input_save_state_btn = "7"
    input_load_state_btn = "6"
    input_reset_btn = "1"
    input_shader_prev_axis = "-1"
    input_shader_next_axis = "+1"

    I have applied a single shader and it works…. but i cannot get the shader switching to work.

    Also the STATE Hotkeys work – but not the Shaders

    Any ideas?

    PS I have updated the binary as well.

    • This reply was modified 1 year, 2 months ago by Profile photo of nemo1966 nemo1966.
    • This reply was modified 1 year, 2 months ago by Profile photo of nemo1966 nemo1966.
    • This reply was modified 1 year, 2 months ago by Profile photo of nemo1966 nemo1966.
    • This reply was modified 1 year, 2 months ago by Profile photo of nemo1966 nemo1966.
    #115792
    Profile photo of nemo1966
    nemo1966
    Participant

    Seems to be broken – RetroPie seems to be getting more and more abstracted and less seems to work. 🙁

    #119340
    Profile photo of mydriaze
    mydriaze
    Participant

    Any update on this? I can’t cycle through the shader neither. Xboxcontroller config file seems ok, but nothing is working.

    By the way, I just plugged in keyboard, but the “m” and “n” key are not working. Can someone confirm if it’s working or not at the moment with the last build?

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar