Holding Select Button Problem – Game Boy Color

Home Forums RetroPie Project Everything else related to the RetroPie Project Holding Select Button Problem – Game Boy Color

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of ando ando 1 year, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #109375
    Profile photo of ando
    ando
    Participant

    Hello,

    Not sure if anyone else has encountered this problem, but in The Legend of Zelda Link’s Awakening when you’re in the item menu you’re supposed to be able to hold the Select button which causes an info graphic regarding Link’s armor, heart pieces, etc to slide up from the bottom of the screen. But when I hold Select in retropie it acts as if I have just tapped the button for a split second instead of actually holding it down. Select seems to work fine with other roms but this is the only game I’ve tested where you actually need to hold the button. Has anyone else had this problem?

    I’ve tried both GBC emulators in retropie as well as 2 different controllers and I have the same problem. I’ve also tested this rom on a windows emulator and I’m able to hold Select with no issues.

    Edit: Meant to mention that I’m still using Retropie 3.1

    Edit2: Also, pressing Select to bring up the map also does not work.

    • This topic was modified 1 year, 5 months ago by Profile photo of ando ando.

    #109603
    Profile photo of ando
    ando
    Participant

    I’ve updated to 3.2.1 and I’m having the same problem. Could this be a retropie issue?

    #109634
    Profile photo of dankcushions
    dankcushions
    Participant

    you’ve encountered my biggest issue with retroarch 🙂 it’s because your select button is your hotkey (i’m guessing).

    boring explanation here:
    the retroarch input handler waits for the user to press the hotkey (select), when that happens it blocks ALL inputs as it’s watching for all the various hotkey combos (select + start = quit, etc). it just so happens it lets 1 frame of input go through at the start of this process, so anything that is only looking for 1 frame of select will work (which is MOST things that use select), but everything looking for me more will not (eg your issue, some mame games looking for more than 1 frame of a coin-input signal, etc)

    solutions:
    – move the hotkey to another button
    – use a non-retroarch emulator
    – wait for a fix (which might be soon!): https://github.com/RetroPie/RetroPie-Setup/issues/1072

    hope that helps!

    #109704
    Profile photo of ando
    ando
    Participant

    Ah, thanks so much for the explanation, dankcushions! Very interesting. So it sounds like if I replace Select with any other gamepad hokey it will have the same problem where the button can’t actually be held. But in the case of Select most games don’t require it to be held so generally it works out fine. You know what, I’ve had issues with the hotkeys before (accidental reset, etc) and I think I’m going to attempt to disable all the gamepad hotkeys and just use a keyboard if I want to exit the game or save state. This isn’t ideal but it should be a nice workaround for me.

    Thanks again for the info!

    Edit: I’ve scrubbed through this video and at the 21 minute mark Floob describes the Select button as the ‘enable hokey button’, similar to holding alt on the keyboard if you have your keyboard hotkeys set up that way. Thanks to herbfargus for providing the link to this video previously.

    • This reply was modified 1 year, 5 months ago by Profile photo of ando ando.
    #109711
    Profile photo of ando
    ando
    Participant

    Well I think I have the Select button working in Zelda now! I went into the config file for my NES30 Joystick and commented out all of the following text:

    # input_enable_hotkey_btn = “6”
    # input_exit_emulator_btn = “7”
    # input_reset_btn = “3”
    # input_menu_toggle_btn = “1”
    # input_state_slot_decrease_axis = “-0”
    # input_state_slot_increase_axis = “+0”
    # input_save_state_btn = “5”
    # input_load_state_btn = “4”

    A bit unfortunate that I need a keyboard connected but that’s ok. I think ideally I would have it so you could exit the emulator by pressing Select, Start, L & R all together but without the button holding / enable hotkey issue.

    • This reply was modified 1 year, 5 months ago by Profile photo of ando ando.
Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar