Help – Im an idiot

Home Forums RetroPie Project New to RetroPie? Start Here! Help – Im an idiot

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of gamesfan gamesfan 1 year ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #119959
    Profile photo of gamesfan
    gamesfan
    Participant

    So, I just updated from 3.5 to 3.6, all went well until I edited the Es_systems.cfg
    Just a couple routine edits, removed \ added some rom filter extentions.. No big deal.

    It was the way I edited it.. See I have altered the Samba shares so I can get to the file easily, in previous versions the permissions on the file wasnt a big deal. I included a snippet below of my SMB config entry (at the end of my post). The issue I believe started with the force user ROOT

    Once I edited that file, I could no longer restart \ shutdown from the retropie emnu. I think this new version wanted to do something with the file and it was no longer owner.

    So. being the idiot I am ran this command.
    sudo chown pi:pi /etc/emulationstation/es_systems.cfg
    I thought it would change the owner back to pi… it didnt. it gave me another error.
    In my infinate wisdom (or lack there of) I ran this command.
    sudo chown -R pi:pi /etc/
    I thought, this may force it.. boy it did alot more than that. Its like ROOT is gone. I cannot Sudo anything.

    And when I try and shutdown or alter any settings now I get this nifty error.
    NO VALID SUDOERS FOUND, Quitting, Sudoers is owned by UID 1000 , should be 0
    Unable to initilize policy plugin

    Is there a way to fix this that does not invole starting over.. Please linux gurus I need some help here.

    [ES Menu]
    comment = ES Menu
    path = /etc/emulationstation/
    writable = yes
    guest ok = yes
    read only = no
    inherit acls = yes
    public = yes
    create mask = 0775
    directory mask = 0775
    force user = root

    #119963
    Profile photo of meneerjansen
    meneerjansen
    Participant

    I too made somre prety stupid mistakes on RetroPie w/ the chown and chmod commands. The Linux system (and especially the sudo command) is pretty picky when it comps to ownership rights etc.

    As for your sudo problem see this link:

    chown root:root /etc/sudoers 
    chmod 440 /etc/sudoers
    chown -R root:root /etc/sudoers.d
    chmod  755 /etc/sudoers.d 
    chmod  440 /etc/sudoers.d/*

    If you’re as unlucky as I was then you might run into some more troubles when other parts of the Linux system start noticing that you messed up the rights in the /etc/ folder.

    #119964
    Profile photo of dudleydes
    dudleydes
    Participant

    I can’t help with your permissions issues but for future reference, you can create a copy of es_systems.cfg in the /home/pi/.emulationstation folder and make your changes here. ES will use this one before the one in etc/emulationstation.

    You don’t have to include any systems that you are not using but you will need to remember to update it from the one in etc/emulationstation if you install new systems.

    #119976
    Profile photo of gamesfan
    gamesfan
    Participant

    Team,
    it appears root is not enabled and I cant set a root password with sudo as it is broken. Otherwise I blieve meneerjansen would have got me straightend up. I have leared alot about linux with this fun project. I have a backup I made with Winimage thankfully that isnt too far behind.

    Dudleydes , thank for your suggestion. I will use your idea.

    Thanks everyone for your time. We can close this. It is totally my fault and the resolution is to start over and dont do what I did again.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar