HDMI no sound Bug : need help !

Home Forums RetroPie Project Everything else related to the RetroPie Project HDMI no sound Bug : need help !

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 16 replies, has 8 voices, and was last updated by Profile photo of fondlebus fondlebus 2 years ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #90114
    Profile photo of sengui79
    sengui79
    Participant

    hello retropie friends !

    i’ve got a problem with the hdmi.
    i am on a RASP pi b+ and on some tv there is no sound.

    the power supply is a good one (with 2000mA) and the HDMI is the same for all tested TV.

    on my tvs (samsung and Panasonic) and my computer (iiama) i’ve got the sound by HDMI but when i try on (for exemple) a sony bravia, LG no sound HDMI.

    I try all the modifications on the TV but no results (for in formation the raspberry audio output works)…

    Please HELP ME !!!!!!

    #90117
    Profile photo of InsecureSpike
    InsecureSpike
    Participant
    #90118
    Profile photo of sengui79
    sengui79
    Participant

    Thanks @insecurespike i’ll try this solution !!!

    i hope to find a solution beacuse i don’t understand why that’s work on sone TV but not for All tv ….. /(

    i’ll give you a feedback tomorrow !

    #90131
    Profile photo of richardpi
    richardpi
    Participant

    That should work. With my computer’s monitor with HDMI all worked immediately also, with pi b and b+.

    When connecting to my Samsung HD tv, and the pi b everything was finetoo. With the pi b+ there also wasn’t any sound. Setting hdmi_drive=2 solved the issue immediately.

    Some HDMI equipment interpretates the incoming signals a bit different than others. This setting solves the issue probably right away.

    #90246
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    worked perfect for me too!

    Sent from my iPhone using Tapatalk

    #90255
    Profile photo of sengui79
    sengui79
    Participant

    Pfuuuu. Tested but doesnt work with a lg and sony tv …. i dont understand ….

    #90284
    Profile photo of labelwhore
    labelwhore
    Participant

    Works on my end on a Sony Bravia and a visio.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #90285
    Profile photo of sengui79
    sengui79
    Participant

    On your bravia you add the hdmi_drive=2 line ? Because i dont saw any differences 🙁
    Other ideas ?

    #90300
    Profile photo of InsecureSpike
    InsecureSpike
    Participant
    #90302
    Profile photo of richardpi
    richardpi
    Participant

    You did save the file after the change?
    Sounds dumb but I did edit mine in the past with sudo nano, but forgot to save with ctrl-x I thought.

    I found an old tutorial on my computer. From what I remember I did try this in the past on a spare sd card just to test, and from there things worked out well. Maybe you can try this aswell, just to be sure where to begin searching the base of the problem.

    Maybe not, but I’ll post it anyway, hope it can help you a bit too.

    [Code]
    Instuctions for others who may be experiencing the same issue with a TV and the Raspberry Pi:

    1. Install a fresh image

    2. start-up the Raspberry Pi and let it set itself up (normal set-up)

    3. After you have gone through normal set-up:

    a. Log-in as a normal user (debian image: pi)

    b. Type the command: “sudo nano /boot/config.txt ”

    c. Press enter

    d. Type in: “hdmi_drive=2 ” [exactly as it is here]

    e. Then press crtl + o

    f. Press Enter

    g. then press crtl + x

    4. Restart using the command: ” sudo shutdown -r now ”

    [/code]

    #90304
    Profile photo of labelwhore
    labelwhore
    Participant

    On your bravia you add the hdmi_drive=2 line ? Because i dont saw any differences :(
    Other ideas ?

    Yep, I have that line in my config.txt. Actually, I seem to remember that config.txt had that line already, I just uncommented it.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #92932
    Profile photo of slipzero
    slipzero
    Participant

    hdmi_force_edid_audio=1

    worked for me

    #92940
    Profile photo of pattaboy
    pattaboy
    Participant

    I had the same issue. ended up doing this.

    RETROPIE BOOT CONFIG

    sudo nano /boot/config.txt
    uncomment hdmi drive 2

    #93426
    Profile photo of postman87
    postman87
    Participant

    Hi all,

    I’m having this same exact problem with retropie 3.0 beta.
    I tried this solution but somewhere in the config.txt there allready is a line that says hdmi_drive=2 . I’m not sure what I’m doing wrong here, so help would be appreciated. My config.txt looks like this. I did not edit anything, it came like this after installing 3.0 beta.

    ___________________________________________________________________________

    # uncomment if you get no picture on HDMI for a default “safe” mode
    #hdmi_safe=1

    # uncomment this if your display

    has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1

    #

    uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if

    there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    # uncomment to force

    a console size. By default it will be display’s size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    #

    uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    # for more options see

    http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256

    overscan_scale=1

    _____________________________________________________________________

    thanks in advance!

    #93431
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    hey just edit the file by deleting/u commenting the # in front of hdmi_drive=2 then save exit and reboot

    #93432
    Profile photo of postman87
    postman87
    Participant

    Ok nevermind my noobishnes… Forgot to uncomment. works perfectly now!

    #96408
    Profile photo of fondlebus
    fondlebus
    Participant

    So after letting the Raspberry Pi sit with no power for about 5 mins or more, i plugged everything back in and it booted fine with sound. Anytime i did a Sudo Reboot or a sudo shotdown -h now…the next time i turned it on, the picture seemed zoomed in, and no audio came out.

    Make sure you go to the config and set HDMI as your primary, take all options off of auto. But unplugging and walking away for a bit, fixed my issue. It would break again when i left emulation station or tried to go back in anytime within 10mins of there being power. Its lame.

Viewing 17 posts - 1 through 17 (of 17 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar