GPIO adapter not working

Home Forums RetroPie Project GPIO Adapter, ControlBlock etc. GPIO adapter not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of alley-cat-jack alley-cat-jack 1 year, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #107648
    Profile photo of espryon
    espryon
    Participant

    Hello,

    I’m a tech enthusiast and my college wanted me to do a project for an open house but, I’m having issues. When I try jstest js0 or whatever it had in the tutorial I get the “No file or directory found” error. I also couldn’t find your testButton program in the install anymore when I wanted to test the button on the gpio adapter to see if my soldering worked… I will post pictures upon request. I’ve never done something quite like this but, it looked fun and I thought I would give it a shot. I was wondering if anyone could offer me some help and/or advice. Your walkthroughs on the website really need to be updated as it looks like the file hierarchy has changed since then. I’m really wondering what I’m doing wrong, if anyone could help with troubleshooting, it would be most appreciated. I will update /w info upon request.

    Thanks,

    Esp.

    • This topic was modified 1 year, 6 months ago by Profile photo of espryon espryon. Reason: spelling error
    • This topic was modified 1 year, 6 months ago by Profile photo of espryon espryon.

    #107649
    Profile photo of espryon
    espryon
    Participant

    The watermarks are part of the img hosting and are hard to disable. Going to ignore for now and delete images after issues are resolved.

    female connector soldering to ribbon cable

    GPIO adapter soldering front

    GPIO adapter soldering back

    • This reply was modified 1 year, 6 months ago by Profile photo of espryon espryon.
    #108314
    Profile photo of alley-cat-jack
    alley-cat-jack
    Participant

    Access retropie_setup by using sudo ./RetroPie-Setup/retropie_setup.sh
    Select option 3 Setup / Configuration (to be used post install)
    Select option SNESDev (Driver for the RetroPie GPIO-Adapter)
    Reboot pi after installed

    I think this will install jstest as well as the driver for the adapter. It should enable your controller ports though. It looks like you have it wired up correctly, just be sure none of those wires are shoring with others. Be sure you connect it in the correct direction on your adapter however as well as connecting the adapter to the pi in the correct direction.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar