GPIO Adapter headache

Home Forums RetroPie Project GPIO Adapter, ControlBlock etc. GPIO Adapter headache

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 1 voice, and was last updated by Profile photo of goobatroopa goobatroopa 1 year, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #101721
    Profile photo of goobatroopa
    goobatroopa
    Participant

    I apologise from the off, I am very much an amateur when it comes to electronics, as you will tell with my photos.

    I have purchased on of your adapters, thank you, and i have soldered (poorly) all the parts. I have wired it up correctly as best as I can tell and installed SNESDev. I note that Snesdev is running as even when I have no gamepads connected, it shows up as 2 gamepads detected in Emulationstation.

    HOwever, no gamepads are recognised when buttons are pressed. If I Jtest them, still nothing. The axis number does not move from -32767

    I have no idea how to even test the button on the adapter, I did apologise earlier!

    Ive attached some photos for your perusal. I have extended the cables as the ribbon you provided is a little on the short side!

    Attachments:
    #101723
    Profile photo of goobatroopa
    goobatroopa
    Participant

    Wouldnt let me post both pictures on the first post for some reason, so ive added it on a reply.
    Wired to controller ports

    Attachments:
    #101853
    Profile photo of goobatroopa
    goobatroopa
    Participant

    I did notice that I had the crimp connector on the wrong way so I changed this round, but still no go.

    I’m running 3.0 beta 4 on a Pi 2. Currently I’m only able to use a PS3 controller on it.

    – Built from SD image
    – Installed SNESDev from source and in retropie to see if that worked, alas it didn’t.
    – GPIO adapter installed using instructions on PetRockBlock.
    – original snes controllers being used.
    – adapter is wired up to original snes controller board pins.

    • This reply was modified 1 year, 9 months ago by Profile photo of goobatroopa goobatroopa.
    #102220
    Profile photo of goobatroopa
    goobatroopa
    Participant

    Ok I have re soldered the board again as the first effort was poor to say the least and YAY! I have one controller working!

    Well at least it shows up in JTEST and works on the retroarch controller setup.

    My only issue now is that the second controller is not being picked up by Jtest or the retroarch setup.

    Any ideas?

    #102226
    Profile photo of goobatroopa
    goobatroopa
    Participant

    OK, I have the second one working now, so fingers crossed my SnesPi is almost complete.

    Thanks for the help……………

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar