Getting started with V2.1

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of dem1980 dem1980 2 years, 9 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11888
    Profile photo of hulkhaugen
    hulkhaugen
    Participant

    Ok, i had the 1.9.1 version up and running a while back, but hit quite a few problems, got busy doing other stuff and forgot most about it. So yesterday i installed the new 2.1 version, and what an improvement. I’m impressed 😉 NES, SNES, SMS and SMD working great. Mame4all, got MK1 running, but not joystick only keyboard works, but not start, and analog stick instead of d-pad. N64 not working at all. So to list the challenges:

    1. N64 games doesn’t start. I can see the roms start to load, and everything seems ok, the resolution changes, but then it quits and goes back to ES2. If i quit right after, i can still read the loading sequence.

    Core: Starting emulation 1945
    Core: Starting R3400 emulator: Dynamic Recompiler
    Core: Init new dynarec
    Core Status: Stopping emulation.
    Core: R4300 emulator finished.
    Core: Stopping emulation at 3200
    Core Status: Rom closed.
    Powering on HDMI with preferred settings
    

    2. /opt/retropie/configs/all/retroarch.cfg, this seems to be set up only for keyboard, but it does work with joystick also. Well, except for Mame4all. And i want to configure a hotkey combination to exit games. Is there another config file i’m missing?

    3. The Mame roms (this is thin ice for me) have several versions. MK1 only has one version and does work. But MK2 has a r14 and a r32 zip-file in addition to the mk2.zip, and also three listings in ES-Mame. None of them work. Same with MK3. EDIT: I’ve now tried several other games that work, and i usually keep the main version, even though there usually are another us and japan version. Is tat correct? Seems like some games needs more than one rom file. They are 0.37b5.

    4. Minor issue, but the scrapper seems to have issues with dashes. for instance pac-man can’t be located, but i do find it when i check online.

    #11940

    DingDong

    bumping this as I am having the same problem with the N64 emulator. Also cannot seem to get the menu and save slot functions working in psx after editing the config file.

    #11945
    Profile photo of zsprawl
    zSprawl

    At the end of the retroarch.cfg file, it is a good idea to add the following to allow you to press select+start to exit the game.

    input_enable_hotkey_btn = “6”
    input_exit_emulator_btn = “7”

    I also like to take advantage of the save and load states in emulation, which some people consider cheating. Add the following lines to enable these buttons on your joypad.

    input_save_state_btn = “8”
    input_load_state_btn = “10”

    Keep in mind, you must hold the “input_enable_hotkey_btn” to trigger the other functions. In other words, using save state would require you to press button 6, and hold it while pressing button 8.

    #11954
    Profile photo of smatticus
    smatticus
    Participant

    the hotkeys do not work for mame, as mame still uses its own config it seems, so if i have my keyboard plugged in i just do the whole “tab” thing and go from there. But i don’t want to use a keyboard every time i want to configure a game for mame, also it doesn’t save any changes i make. how can i get mame to use the same settings as everything else?

    #11973
    Profile photo of Mutex
    Mutex
    Participant

    the hotkeys do not work for mame, as mame still uses its own config it seems, so if i have my keyboard plugged in i just do the whole “tab” thing and go from there. But i don’t want to use a keyboard every time i want to configure a game for mame, also it doesn’t save any changes i make. how can i get mame to use the same settings as everything else?

    The mame emulator cannot save the config since you’re running mame as pi user. The config folder in the mame emulator belongs to the root user, so you’re not allowed to make any changes to that folder. The easiest thing would be to run mame one time by hand as root user
    /opt/retropie/emulators/mame4all-pi/mame
    configure your controls by pressing

    and then restart emulationstation. The pi should now have your new controls saved. The other solution would be to change the ownership of the config file but that is a bit more complicated.

    #11998
    Profile photo of dem1980
    dem1980
    Participant

    If you are using Mame4all and have trouble for checking crc rom, read this :
    http://blog.petrockblock.com/forums/topic/how-to-use-mame4all/#post-11788

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar