GBA not saving gamepad buttons

Home Forums RetroPie Project Everything else related to the RetroPie Project GBA not saving gamepad buttons

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of blackdiamond blackdiamond 2 years ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #17503


    Ok..I ve managed to start playing some gba roms but every time i start a game i have to press F10 and re map my gamepad. I canot see a cfg folder anywhere. How can i save my gamepad controls?



    I guess it smth with the permissions?



    Found the solution.

    The user of gpsp folder (and raspberrypi folder as well) shoulp be pi and not root !!



    Can you post the code that you used? I’m having the same issue and have changed the permissions, but the config file still won’t save.



    Run gba emulator and hit F10 for keyboard. A new screen comes. Map joystick. If you restart game and gamepad needs re-mapping then you have to change permissions.

    In ssh type:

    ls -ld /opt/retropie/emulators/gpsp/raspberrypi

    For changes to be saved, the user should be pi, not root. The output when this command is run should be similar to below.

    drwxr-xr-x 2 pi pi 4096 Jul 8 14:21 /opt/retropie/emulators/gpsp/raspberrypi

    If root is the owner, then change the user to pi with the following command.

    sudo chown -R pi:pi /opt/retropie/emulators/gpsp/raspberrypi

    Quick question: Have you experiencing any sound appearings and dissapearings?

    Profile photo of hazza4569

    Hey guys, I’ve had the same issue with having to configure every time I open the emulator, but have been unable to fix it with that code?

    I’ve tried everything I can think if but nobody seems to have a solution?

    Help would be much appreciated – really don’t wanna have to configure controller every time I play.

    Profile photo of blackdiamond

    I got the same problem. I tired the script, everything but it was not possible to save the settings.

    Then i tried one thing : in /opt/retropie/configs i created a folder called gba.
    Then I launched a gba rom, go to settings menu with F10, set the buttons and exit….inside gba folde a gpsp.cfg was created and then the settings are finally stored!

    I hope this will be useful for everyone!

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar