Font Errors When Applying a Theme

Home Forums RetroPie Project Emulation Station Themes Font Errors When Applying a Theme

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Keigan Keigan 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #84520
    Profile photo of atrieder
    atrieder
    Participant

    I use my Raspberry Pi on a low resolution composite screen, but the default theme in Emulation Station is difficult to read. I have been working on a theme with easier to read text, but I keep running into the following errors when I apply the theme(Shown in the console via ssh):

    lvl0: from theme “/etc/emulationstation/themes/simple4/gb/theme.xml”
    Included file “./../simple.xml” not found! (resolved to “/etc/emulationstation/themes/simple4/gb/../simple.xml”)
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/gba/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/gba/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/gbc/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/gbc/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/nes/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/nes/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/nes/../../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/nes/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/nes/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/snes/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!
    lvl0: Error creating font face! (mPath: /etc/emulationstation/themes/simple4/snes/../art/CHICAGO.TTF, data.length: 0)
    lvl0: Error – tried to build TextCache with Font that has no texture loaded!

    At the same time, Emulation Station crashes and returns to the console. I have been testing the theme on a Windows installation of Emulation Station, and I haven’t had any crashes. Moreover, another theme that uses a different font (piulator by phrazelle) works fine on the Raspberry Pi. Based on the errors, do I need to do anything to the font file I am using, or look for a specific type of font? I have attached a working font (NEWTOW_.TTF from piulator) and the font that I am trying to use (CHICAGO.ttf) below.

    #89622
    Profile photo of phrazelle
    phrazelle
    Participant

    Did you get this worked out? I’m curious as to what the issue was if you solved it.

    #89766
    Profile photo of atrieder
    atrieder
    Participant

    I was able to get the theme working when running Emulationstation at a very low resolution (160 by 120), but resolutions like 320 x 240 or 640 x 480 crash after selecting a system. On the lower resolutions, some new errors came up. After looking at these errors, it seems like this is because of the increased text sizes and changed theme images (using too much RAM? Most of the new errors referred to glyph size). I will strip my theme down to only text to see if that fixes the errors.

    • This reply was modified 2 years, 1 month ago by Profile photo of atrieder atrieder.
    #89821
    Profile photo of Keigan
    Keigan
    Participant

    My initial thought would be that there are glyph’s in your game titles that are not available in the font. But I’m not too sure. I’ve had the issue before, but I changed to a different font that still works with the design and it’s all gone now.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar