First attempt: RetroPie does not boot, red light only

Home Forums RetroPie Project Everything else related to the RetroPie Project First attempt: RetroPie does not boot, red light only

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of venkatrl venkatrl 2 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #6787
    Profile photo of venkatrl

    Hello all,
    I am new to my Raspberry Pi (512 model B), and my first project is to get RetroPie up and running. I followed the instructions exactly as presented on this site:
    in order to format my SD card and load the RetroPie image onto it.

    However, once I plug in the SD card into the Raspberry pi (followed by the HDMI cable, my keyboard, an XBOX 360 USB controller, and a ethernet cable). Then I attempt to power on the raspberry pi by plugging in the (5V 1AMP) power source.

    Only the red light indicating “POWER” lights up. Nothing is displayed on the screen. I have tried this on multiple monitors. This error occurs even when I re-format and re-flash RetroPi (both on windows and mac), I have made sure that I can re-format the card and read its contents on multiple computers (so it is likely not the SD).

    Additionally, I have tried a few steps suggested on this site regarding the abnormal light:
    (for example, trying the alternate bootcode.bin posted on that site. No luck. Also tried booting it up with just the SD card and the power – which allegedly produces the “OK light” for 20 seconds. Also not happening).
    I’m at a loss because it seems that the process should work… Is my hardware faulty?

    Any help would be greatly appreciated. I’m happy to answer anything to clarify the situation.



    Profile photo of trimmtrabb

    Sounds like power issues, either the PSU or the usb cable. I had the same problem a while ago and turned out to be the usb cable, the cheap ones can cause issues.

    If you have found the solution to your problem please mark the topic as resolved.

    Profile photo of venkatrl

    I isolated the problem to the SD card. Swapped in another and it had no problem booting.



Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar