FBA Retroarch core – coin controls

Home Forums RetroPie Project Everything else related to the RetroPie Project FBA Retroarch core – coin controls

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 31 replies, has 15 voices, and was last updated by Profile photo of collserolabiker collserolabiker 1 year, 5 months ago.

Viewing 32 posts - 1 through 32 (of 32 total)
  • Author
    Posts
  • #89226
    Profile photo of Billy T. Pilgrim
    Billy T. Pilgrim
    Participant

    Hi all,

    Got a slightly odd problem running the FBA retroarch core. I’m trying to run as much as I can through Retroarch to take advantage of shaders, overlays etc.

    I’ve run into a weird problem with some games – they won’t register a coin being inserted, so i can’t get into start the games properly. Everything’s running at full speed and controls are mapped fine to Retroarch.

    It seems to be mostly, but not limited to, Capcom games – others run fine including some that wouldn’t run at all on PiFBA on my last install. The core’s log shows that the controls are mapped the same on the ones that don’t work as the ones that do – Select button for P1 Coin, Start button for P1 Start. I don’t know if the other controls are working, as I can’t get past “Insert Coin” to try them.

    Has anyone else run into this problem? I’m on a RPi2, at the RPi2 overclock setting, and I’ve tried with both a wired 360 controller and a replica SNES controller.

    Games that don’t work: Any of the Marvel/Street Fighter series, Aliens Vs. Predator, many more

    Games that do work: Any Metal Slug game, Final Fight, many more

    #89230
    Profile photo of peanut
    peanut
    Participant

    it’s your lucky day! atleast I hope you are having the same problem as I had. so here goes.

    One way to see wether your controls are working in FBA is to use the insert coin/start on your keyboard…. one you have done that you should be able to play the game. Move around, shoot jump etc :p

    my standard retroarch said buttons 8 and 9 are start and select but in the fba2x.cfg located in fba emulator folder the start and select buttons needed to be 6 and 7…

    anyways give it a shot It might be a solution or bring you closer to it.

    • This reply was modified 2 years, 2 months ago by Profile photo of peanut peanut.
    #89241
    Profile photo of Billy T. Pilgrim
    Billy T. Pilgrim
    Participant

    Hi Peanut,

    Sadly, the issue I’m having isn’t in PiFBA, it’s in the FBA retroarch core – that means there aren’t any config files to play with.

    The FBA core seems to decide for itself what controls it assigns to what – it comes up as the rom is booting – but there doesn’t seem to be anywhere you can change it yourself. As I said, it’s saying that P1 Coin is mapped to retroarch joypad Select, and that’s definitely mapped to the controller select button in Retroarch.

    It’s weird, I’m wondering if it might affect all games for a particular hardware or something.

    #89243
    Profile photo of Billy T. Pilgrim
    Billy T. Pilgrim
    Participant

    Looking down the game list, everything I’ve had trouble with seems to run on CPS2 hardware – but then again, I know I’ve played at least one CPS2 game (1944: the Loop Master) which worked perfectly on this setup.

    #89248
    Profile photo of foroluis
    foroluis
    Participant

    I have a similar problem with fba-libretro, the controls aren’t well configured, but just for some games of fba-libretro, other cores are executed without problems using the same config file.

    I have tried 1944 and it works! but SF2 (CPS2) or SF3 (CPS3) didn’t work, I can’t insert coin.

    #89257
    Profile photo of Billy T. Pilgrim
    Billy T. Pilgrim
    Participant

    I’m going to try compiling this core:
    https://github.com/libretro/libretro-fba
    to see if that works.

    It says it’s only 6 days old and there’s nothing about FBA in the recent commits to RetroPie-Setup, so I’m guessing the one RetroPie-Setup installed is this one:
    https://github.com/libretro/fba-libretro

    It’s got to be worth a shot.

    #89267
    Profile photo of killer101
    killer101
    Participant

    Hi,

    I ran over the same problem while trying to play ’88 Games. This happened with the FBA libretro core. To test it, I ran ’88 Games against the MAME libretro core (I think it’s based on iMame4All) and the result was the same. Maybe it’s not a core fault, seems to be an issue with RetroArch.

    #89284
    Profile photo of polluxpt
    polluxpt
    Participant

    This was my solution to a similar problem:

    http://blog.petrockblock.com/forums/topic/fbalibretro-controller-config/

    I hope it will help someone.

    #89446
    Profile photo of killer101
    killer101
    Participant

    Considering polluxpt solution I found a somewhat easier solution for autodetect controllers like the PS3 one.

    Just go to …

    /opt/retropie/emulators/retroarch/configs/

    Find the config file for your controller and change the line

    input_enable_hotkey_btn = “0”

    to another button.

    Here “0” stand for the Select button on the PS3 Controller. I changed it to “8” which is the left trigger. No more coin problem!

    To exit an emulator you must now press left trigger and start!

    • This reply was modified 2 years, 2 months ago by Profile photo of killer101 killer101.
    #89452
    Profile photo of polluxpt
    polluxpt
    Participant

    This is a easier solution but changes the hotkey to all emulators (in case you use multiple systems like me).
    My solution just apply the change to fbalibretro and you can still exit by pressing Select+Control (has this is configured in retroarch.cfg file).
    You have now two possible solutions for your problem which is good because you can choose the one that fits you best.

    #89456
    Profile photo of killer101
    killer101
    Participant

    You’re right, but I personally don’t care if I have to press left trigger + start or select + start on all emulators. That is for everybody to decide for themselves.

    If you use my solution, you will also get rid of the coin problem in mame. It’s the same like with FBA.

    #89475
    Profile photo of polluxpt
    polluxpt
    Participant

    I agree with you.
    That’s the beautiful thing of this… anyone can choose what it fits better.
    Btw in MAME I got coin working fine.

    #89478
    Profile photo of killer101
    killer101
    Participant

    I think that is why you have most of the games running under FBA. I just came across it while searching for the coin problem. To test it run ’88 Games in MAME and there it is.

    #89484
    Profile photo of polluxpt
    polluxpt
    Participant

    Not really I tried just a few games while setting up Retropie (Sunset Riders, Pang, Cadillacs & Dinosaurs and The Punisher).
    I just tried FBA with the games that did not work in MAME.
    The coin issue came while trying different FBA emulators(looking for a 4:3 setup).
    I don’t have my rom set copied into my USB pen drive (because I’m waiting for it) but will copy them soon and I can check it.
    So far it seems like when I had a Dingoo… some games work in a different emulator. I will know it in a few weeks.

    #89828
    Profile photo of polluxpt
    polluxpt
    Participant

    I tried ’88Games and I my coin (Select) button did not work like yours (this game works fine in FBA?).
    I tried other few games and they were ok (Mortal Kombat, Snow Brothers, Samurai and NBA Jam).
    I tried Moon Walker and it failed so I guess I will try it in FBA later.
    I tried Run N Gun as well but it said the game is not supported (my rom set did not have this game included but I really would like to be surprised… hehehe).

    #89838
    Profile photo of killer101
    killer101
    Participant

    Without the changes to the hotkey, the coins in ’88 Games didn’t work in FBA and Mame. So I suggest it is an issue with retroarch and not the FBA core!

    #89840
    Profile photo of buzz
    buzz
    Keymaster

    I’m going to try compiling this core:

    https://github.com/libretro/libretro-fba

    to see if that works.

    It says it’s only 6 days old and there’s nothing about FBA in the recent commits to RetroPie-Setup, so I’m guessing the one RetroPie-Setup installed is this one:

    https://github.com/libretro/fba-libretro

    It’s got to be worth a shot.

    you think they could come up with a slightly more descriptive repository name than switching the order of the name – confusing!

    #89844
    Profile photo of barbudreadmon
    barbudreadmon
    Participant

    <div class=”d4p-bbt-quote-title”>billyt-pilgrim wrote:</div>
    I’m going to try compiling this core:

    https://github.com/libretro/libretro-fba

    to see if that works.

    It says it’s only 6 days old and there’s nothing about FBA in the recent commits to RetroPie-Setup, so I’m guessing the one RetroPie-Setup installed is this one:

    https://github.com/libretro/fba-libretro

    It’s got to be worth a shot.

    you think they could come up with a slightly more descriptive repository name than switching the order of the name – confusing!

    Description is quite clear :
    libretro-fba : Port of Final Burn Alpha to Libretro (recent mainline version). It means it is a port of current fba (v0.2.97.34). I wrote it, feel free to report issues on github.

    #89847
    Profile photo of buzz
    buzz
    Keymaster

    yeh the description, but I think the actual repository names should be more distinct if they are going to have two ongoing developments – maybe the word mainline should be included. anyway, it’s not a big deal 🙂

    #93012
    Profile photo of Floob
    Floob
    Moderator

    This is a pain that the controls dont seem consistent across the roms with the installed fba-libretro. (i.e. the select button wont always trigger credits)

    Its a shame as it supports such a recent version of romsets.

    I’ll post polluxpt solution again.

    http://blog.petrockblock.com/forums/topic/fbalibretro-controller-config/

    Has anyone had better experience with libretro-fba from barbudreadmon above?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    • This reply was modified 2 years, 1 month ago by Profile photo of Floob Floob.
    #93014
    Profile photo of Floob
    Floob
    Moderator

    Ok, two things.

    1) On the roms (i.e Lightning Fighter) that dont accept “Select” as the coin button, using the keyboard version of “Right Shift” works fine for coin, the joypad then functions correctly.

    OR

    2) By swapping the hotkey enable button to anything else (in my case left trigger) in /opt/retropie/configs/fba/retroarch.cfg (this way all other libretro emulation keeps using select as the hotkey) everything then works fine (as in, select then works as coin).
    I simply added this line to that file
    input_enable_hotkey_btn = "4"

    either of these solve the problem.

    Can anyone who knows how fba-libretro handles inputs, see what the cause may be based on the resolutions above working?

    Either way, I’m happy it works now 🙂

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97808
    Profile photo of phoenix
    phoenix
    Participant

    Floob has it right. I am on 3beta on a pi2. I first tried remapping the exit combo (that another person recommended) and it did not work.

    However, remapping the hotkey by adding Floob’s line to the retroarch.cfg files for fba-lr and imame4all-lr work for all games that the [rSHIFT] keyboard button had been working for to add coins.

    Getting MAME games to play nice is not for the faint of heart.

    #102036
    Profile photo of kommissar
    kommissar
    Participant

    Hi everybody !

    I got the same problem with some cps2 roms. I swapped SELECT for L as “hotkey enabler”.
    Basically, i add this line in the cps2/retroarch.cfg (i added a cps2 menu, that s why it s not fba folder) :

    
    input_enable_hotkey_btn = "4"
    

    to override this line in the controller config :

    
    input_enable_hotkey_btn = "6"
    

    And it works… not completely.

    For the game nwarr.zip (Night warriors, one of my fav saturn game :D), when i long press on [L], the emulator considers it is a short press. I also tried by swapping triggers for hotkey enabler, same bug (respectively on [R]).

    Way to reproduce that :
    * Put [L] as hotkey enabler.
    * In “Night Warriors: Darkstalkers’ Revenge” (rom : nwarr.zip), play as Victor (Frankenstein).
    * Perform a short press on L : Victor hits with a BIG punch
    * Perform a long press on L : Victor hits with a BIG punch (the bug is here, he must hit with a big electrified punch)
    (If you don’t know the game, perform a short/long press on [R], you will see what i mean by electrified hit)

    For info : I updated retroarch via retropie-setup, I use a Buffalo SNES controller.

    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    • This reply was modified 1 year, 9 months ago by Profile photo of kommissar kommissar.
    #102073
    Profile photo of dankcushions
    dankcushions
    Participant

    another (sort of) solution for this issue is to use player 2’s coin button. eg, if i have two USB SNES controllers plugged in, I can hit ‘select’ on player 2 and it puts a credit in. you have to be careful to then press start on player 1, or you might end up with 2 players joining the game (if you’re playing alone!)

    it looks like the fba/mame libretro cores don’t like having the hotkey as the same key for the coin button. that makes the above make sense, as only the p1 controller has a hotkey (you can’t start-select quit with p2, by default).

    has anyone logged a ticket with retroarch? with a bit of luck this issue is fixed in 1.2 already.

    #102076
    Profile photo of charco
    charco
    Participant

    I still can’t exit from lr-fba with Start + Select no matter what I have tried with configs etc. I’ll wait until Retropie 3.0 stable release when there are less issues. Until then I’ll put the Pi away and stick with Windows RetroArch v1.2.1.

    #102084
    Profile photo of kommissar
    kommissar
    Participant

    Nice trick dankcushions !!!!
    It works perfectly. Good job !

    #102184
    Profile photo of dankcushions
    dankcushions
    Participant

    🙂

    I logged the issue here: https://github.com/libretro/fba-libretro/issues/46

    It seems it was already logged for the Mame4All Libretro core: https://github.com/libretro/imame4all-libretro/issues/9

    It might be a retroarch issue, though…

    #102192
    Profile photo of herbfargus
    herbfargus
    Moderator

    There is a solution in the latest retroarch- called core input remapping: if you reinstall retroarch from menu 5 in the setup script (after updating the setup script of course) and open up into the rgui (by pressing select+x)- under the quick menu you can change which core options do what- so you could switch start and select so start is the coin input and select is start or any other variation that is comfortable. That way you don’t have to give up a control if you wish to still be able to put coins in. You’ll just have to make sure that the RGUI saves the configs on exit.

    #102289
    Profile photo of dankcushions
    dankcushions
    Participant

    There is a solution in the latest retroarch- called core input remapping: if you reinstall retroarch from menu 5 in the setup script (after updating the setup script of course) and open up into the rgui (by pressing select+x)- under the quick menu you can change which core options do what- so you could switch start and select so start is the coin input and select is start or any other variation that is comfortable. That way you don’t have to give up a control if you wish to still be able to put coins in. You’ll just have to make sure that the RGUI saves the configs on exit.

    i have the latest version of retroarch but not sure what you mean? in ‘armored warriors’ (a game that suffers from this issue) in ‘quick menu’ > ‘core options’, I have a ‘controls’ option but it’s just the option for ‘gamepad’ or ‘arcade’ ? doesn’t seem to be anything else i can set here

    #104234
    Profile photo of blockaboots
    blockaboots
    Participant

    Ok i change the hotkey to something different but when i start the game again, it seems to revert back to what it originally was and the setting i made doesnt appear to skick. Any ideas?

    • This reply was modified 1 year, 8 months ago by Profile photo of blockaboots blockaboots.
    #104299
    Profile photo of Floob
    Floob
    Moderator

    @blockaboots

    You could run this and make the zip available so I could check your config?
    zip -r /opt/retropie/configs/all/config-details.zip /opt/retropie/configs/*

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #110824
    Profile photo of collserolabiker
    collserolabiker
    Participant

    Definitely, I need help, I think I tried all but nothing success to INSERT COINS.
    I have two players connected directly to GPIO.
    Each player has START + SELECT + 6 BUTTONS + JOYSTICK
    ES works with SNES Emulator, no problem, I can choose the emulator and play to Street Fighter, but I can not play to MAME games !!!

    The problem, is the Insert Coin, I try all, but doesnt work !!

    I am going to write all my retroarch.cfg

    /opt/retropie/configs/all/retroarch.cfg
    auto_remaps_enable = true
    input_player1_joypad_index = “0”
    input_player1_b_btn = “1”
    input_player1_y_btn = “3”
    input_player1_select_btn = “6”
    input_player1_start_btn = “7”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “0”
    input_player1_x_btn = “2”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player2_joypad_index = “1”
    input_player2_b_btn = “1”
    input_player2_y_btn = “3”
    input_player2_select_btn = “6”
    input_player2_start_btn = “7”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “0”
    input_player2_x_btn = “2”
    input_player2_l_btn = “4”
    input_player2_r_btn = “5”
    input_enable_hotkey_btn = “3”
    input_exit_emulator_btn = “5”

    /opt/retropie/configs/all/retroarch-joypads/GPIOController1.cfg
    input_device = “GPIO Controller 1”
    input_driver = “udev”
    input_r_btn = “5”
    input_save_state_btn = “5”
    input_start_btn = “7”
    input_exit_emulator_btn = “7”
    input_l_btn = “4”
    input_load_state_btn = “4”
    input_up_axis = “-1”
    input_a_btn = “0”
    input_b_btn = “1”
    input_reset_btn = “1”
    input_down_axis = “+1”
    input_right_axis = “+0”
    input_state_slot_increase_axis = “+0”
    input_x_btn = “2”
    input_menu_toggle_btn = “2”
    input_select_btn = “3”
    input_enable_hotkey_btn = “6”
    input_y_btn = “3”
    input_left_axis = “-0”
    input_state_slot_decrease_axis = “-0”

    /opt/retropie/configs/all/retroarch-joypads/GPIOController2.cfg
    input_device = “GPIO Controller 2”
    input_driver = “udev”
    input_l2_btn = “4”
    input_start_btn = “7”
    input_exit_emulator_btn = “7”
    input_up_axis = “-1”
    input_a_btn = “0”
    input_b_btn = “1”
    input_reset_btn = “1”
    input_down_axis = “+1”
    input_r2_btn = “5”
    input_right_axis = “+0”
    input_state_slot_increase_axis = “+0”
    input_x_btn = “2”
    input_menu_toggle_btn = “2”
    input_y_btn = “3”
    input_left_axis = “-0”
    input_state_slot_decrease_axis = “-0”

    /opt/retropie/configs/fba/retroarch.cfg
    input_remapping_directory = /opt/retropie/configs/fba/
    input_enable_hotkey_btn = “3”
    #include “/opt/retropie/configs/all/retroarch.cfg”

    /opt/retropie/configs/mame-mame4all/retroarch.cfg
    input_remapping_directory = /opt/retropie/configs/mame-mame4all/
    input_enable_hotkey_btn = “3”
    #include “/opt/retropie/configs/all/retroarch.cfg”

    WHAT CAN I DO ????

Viewing 32 posts - 1 through 32 (of 32 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar