FBA…Can't change control map at all. Im cracking up!!!!

Home Forums RetroPie Project Everything else related to the RetroPie Project FBA…Can't change control map at all. Im cracking up!!!!

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 14 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #87988
    Profile photo of leefy
    leefy
    Participant

    So, HEllo.

    This has been going on for 3 days and i can’t sort it. Ive actually had to sign up to a forum for the 1st time in years to get help…The guides and youtube vids aren’t working and im going to have a mental breakdown. I got my Pi about a week a go. 1st one ever. Managed to config it all and fill it full of roms….I have the DragonRise Inc.Generic USB Joystick which has it’s very own .cfg file but for no reason i can’t work out piFBA an it will not work with the buttons i want….I have 8 main buttons numbered which all work in jstest. They are numbered 0-7….I want to just have 6 buttons 3 bottom and 3 top to spank some fighting games in a little cabinet im building…

    Problem: I reconfigure EVERY .cfg fill i can find…Seriously….It’s any of them now as the main ones definitely aren’t picking up on my re-binds. Main problem is i can’t get button 5 to do anything….nadda….nothing, So my only assumption is that although im altering the button commands in all the seemingly right places im missing something and have cowered on here to beg for help.

    Im adding a picture to see if that inspires anyone to help…

    ….BTW….Great forums here….Ive gone from no idea to full on RetroPi addict in 2 weeks all done with the help on these forums…Only problem is there’s no one asking this question.

    Hope this all makes sense as im writing this in rage/desperation.

    • This topic was modified 2 years, 2 months ago by Profile photo of leefy leefy.
    • This topic was modified 2 years, 2 months ago by Profile photo of leefy leefy.

    Attachments:
    #88002
    Profile photo of chdez77076
    chdez77076
    Participant

    in /opt/retropie/emulators/pifba/fba2x.cfg there is a directory to go to to set up your buttons.

    Maybe paste this file here to see what your current setting are?

    Im at work so im trying to think what i can remember seeing.

    Ive never configured a controller on FBA but im definitely going to so it would help to know as well.

    #88007
    Profile photo of Floob
    Floob
    Moderator

    Yes, you can find it in
    /opt/retropie/emulators/pifba/fba2x.cfg

    Here is the default contents:
    http://pastebin.com/raw.php?i=e2ivW5sM

    You can get your joypad equivalents with the jstest tool.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88085
    Profile photo of leefy
    leefy
    Participant

    I will give that a go in a bit. Thanks. Also big thanks to Mr Floob for your youtube videos. Great help.

    #88090
    Profile photo of leefy
    leefy
    Participant

    Gutted. That’s not worked….I can only assume i’m not editing things right or that there is something going seriously wrong.

    I’ve altered the buttons now to completely random buttons just to see if that changes anything, but it didn’t. Here’s what i did. I only edited the [Joystick] part…Like i said before i’ve only been doing this a week so i may be Noobing things up here. Do i need to remove the # parts to make those lines active?…Im not sure whats going on here….As far as i knew the configs in the “All” folder would overwrite all controls. Again. slightly bummed out by this.

    [Keyboard]
    # Get codes from /usr/include/SDL/SDL_keysym.h
    A_1=306
    B_1=32
    X_1=308
    Y_1=304
    L_1=122
    R_1=120
    START_1=13
    SELECT_1=9
    LEFT_1=276
    RIGHT_1=275
    UP_1=273
    DOWN_1=274
    QUIT=27
    #player 2 keyboard controls, disabled by default
    A_2=999
    B_2=999
    X_2=999
    Y_2=999
    L_2=999
    R_2=999
    START_2=999
    SELECT_2=999
    LEFT_2=999
    RIGHT_2=999
    UP_2=999
    DOWN_2=999

    [Joystick]
    # Get codes from “jstest /dev/input/js0”
    # from package “joystick”
    A_1=8
    B_1=9
    X_1=2
    Y_1=3
    L_1=5
    R_1=6
    START_1=0
    SELECT_1=1
    #Joystick axis
    JA_LR=0
    JA_UD=1
    #player 2 button configuration
    A_2=0
    B_2=1
    X_2=2
    Y_2=3
    L_2=4
    R_2=6
    START_2=9
    SELECT_2=8
    #Joystick axis
    JA_LR_2=0
    JA_UD_2=1

    [Graphics]
    DisplaySmoothStretch=1
    # Display Effect: 0 none, 1 scanlines
    DisplayEffect=0
    DisplayBorder=0
    MaintainAspectRatio=1

    [Sound]

    • This reply was modified 2 years, 2 months ago by Profile photo of leefy leefy. Reason: Spelling Police
    #88107
    Profile photo of Floob
    Floob
    Moderator

    The # will only affect the line it appears on, so thats fine.

    This config will only affect control of games/roms that are put in the home/pi/RetroPie/roms/fba folder, but I presume thats where you have put them?

    Are you sure the button codes you are using are the correct ones for your joypad?
    Which one is it?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88140
    Profile photo of leefy
    leefy
    Participant

    I’ve ran through a load of things again and yup…Im back where i started.All roms are where they should be…Basically anything you’ve said to do in your youtube vids i’ve done…The controller i have is saving as DragonRise Inc.Generic USB Joystick when i do register retroarch controller. Ive done the JStest thingy again and all buttons are exactly where they are supposed to be…There are 11 and they all work exactly to the right position when pressed. I can’t understand what’s going on.

    This is what i’ve done to fba2x.cfg….Like ive said the buttons are random buttons in random places so i can test if they move. It seems just to be for piFBA im having trouble…Other emulators are going great with it.

    [Joystick]
    #Get codes from “jstest /dev/input/js0”
    #from package “joystick”
    A_1=8
    B_1=9
    X_1=2
    Y_1=4
    L_1=5
    R_1=6
    START_1=0
    SELECT_1=1
    #Joystick axis
    JA_LR=0
    JA_UD=1

    • This reply was modified 2 years, 2 months ago by Profile photo of leefy leefy.
    #88165
    Profile photo of Floob
    Floob
    Moderator

    I could be wrong – but shouldnt that read A_0 as opposed to A_1 etc.. ?
    I dont have access to a Pi at the moment to check.

    hmm – yeah after thinking about it I’m pretty sure I’m wrong here.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    • This reply was modified 2 years, 2 months ago by Profile photo of Floob Floob.
    #88167
    Profile photo of Floob
    Floob
    Moderator

    Any chance you could try a different controller to see if thats the issue?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88193
    Profile photo of leefy
    leefy
    Participant

    Hi…I have a nice little Snes USB gamepad too…That does exactly the same as my joystick….The Right Shoulder button should be button 5 and it doesn’t do anything.

    This is what i’ve done now….

    I have another micro SD card so i’ve installed a new retropie img onto it…Then only added Marvel VS Capcom (This is a game i know has a fair few buttons to it) and the neo geo bios. I then got the /opt/retropie/emulators/pifba/fba2x.cfg and did this….(amoung other things..)

    [Joystick]
    # Get codes from “jstest /dev/input/js0”
    # from package “joystick”
    A_1=5
    B_1=5
    X_1=5
    Y_1=5
    L_1=5
    R_1=5
    START_1=9
    SELECT_1=8
    #Joystick axis
    JA_LR=0
    JA_UD=1

    Nothing changed to the button config at all again. I can only assume this isn’t the file i need to change…Or i need to de-activate one somewhere else that is acting as the primary.

    #88205
    Profile photo of Floob
    Floob
    Moderator

    Just checking – the roms arent in here are they?
    ~/RetroPie/roms/fba-libretro

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88259
    Profile photo of leefy
    leefy
    Participant

    No the roms are in the normal place. I transfered them using a usb not filezilla as my wifi had gone mental when I was trying out the new sd img. I’ve googled the hell out of this and there’s not too much going on about the subject. But what I did find was that im meant to change the exact file your saying to change.i may have to make a video just to prove im not a mental . I’ve tried a couple of other games and the buttons are pretty randomly spread out but as before nothing changes when I alter the config.im going to have another look into it tonight.

    #88379
    Profile photo of leefy
    leefy
    Participant

    Still no luck tonight. Tried another usb controller with a new retropie img. Alas nothing. The appears to be someone on Reddit having a similar problem from a short while back. That kinda gives me hope that im not mental. But still….I have no clue what is keeping my buttons the same even though I change them in the fba2x.cfg file. I’ve tried going through retroarch configs and all manner of other things to try and work this out….I’ve read through tonnes of stuff, but nothing….I hope I get it sorted as it really puts a halt on me finishing my mini cabinet and I’ve ordered the 7 inch screen now….Bleh! There seems to be no reason whatsoever for this. I now know why the Raspberry Pi is so small…..It’s so when you finally crack you can lob it far enough never to have to see the damn thing again.

    ***Cries!!***

    All I know is that this config….

    [Joystick]
    # Get codes from “jstest /dev/input/js0”
    # from package “joystick”
    A_1=0
    B_1=1
    X_1=2
    Y_1=3
    L_1=4
    R_1=6
    START_1=9
    SELECT_1=8
    #Joystick axis
    JA_LR=0
    JA_UD=1

    ……is what I get regardless of what I change it to….On 3 separate joysticks/pads.

    #88511
    Profile photo of leefy
    leefy
    Participant

    Great news (for me)….I’ve sorted it out….I downloaded piFBA from their site and deleted the pifba folder in the emulators folder then just uploaded all the new stuff (I Had to 777 all the files…It sent my FBA mental and crashed it). I then ran Marvel Vs Capcom and hey-presto! Button 5 was working…Madness….Beat the living daylights out of MegaMan ALL on 1 button (button 5 of course)…Then promptly quit the emulator to reconfig fba2x.cfg to my main arcade stick buttons. Reloaded it all and it had gone back to default normal rubbish no button 5 nightmare again…Hmmmmm

    I deleted pifba, then uploaded it all again. Button 5 was working….So i took a look at what i was using to edit the code…I was using a free program called “XML Copy Editor” left over from a Hyperspin build I did recently.. Anyways…I’ve downloaded notepad++ now and everything is swell in the Raspberry Pi FBA world and button 5 is going to take a rather large spamming from now on.

    Triumph.

    Thanks for your replies to this possible Noobish problem. You made me focus on the right file for long enough to work this out.

    Attachments:
    #88516
    Profile photo of Floob
    Floob
    Moderator

    If you’re editing files, you may well find it easiest and most reliable to use the terminal interface, and just use nano.
    So for example “sudo nano fba2x.cfg”

    I’d be sorely tempted to use RetroPie 2.6.0 and just go and edit that file using nano.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 15 posts - 1 through 15 (of 15 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar