Everything was good…and now…

Home Forums RetroPie Project Everything else related to the RetroPie Project Everything was good…and now…

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 14 replies, has 3 voices, and was last updated by Profile photo of mikaaville mikaaville 2 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #85518
    Profile photo of mikaaville
    mikaaville
    Participant

    So, it took a clean install of RetroPie but I finally got my USB controller to work, except…I can’t seem to map my escape rom hotkey right, when I do it, everything seems right but when I am in game and I just press X it exits the game, not even what I mapped to escape. Maybe I am missing something, I’m sort of a noob with this.

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “9”
    input_exit_emulator_btn = “8”
    input_enable_hotkey_btn = “9”
    input_save_state_btn = “4”
    input_enable_hotkey_btn = “9”
    input_load_state_btn = “5”

    #85520
    Profile photo of Floob
    Floob
    Moderator

    This may help you setup hotkeys

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85522
    Profile photo of mikaaville
    mikaaville
    Participant

    Ok, I tried to go to setup and I didn’t see the option to enable hotkeys.

    #85524
    Profile photo of Floob
    Floob
    Moderator

    Have you updated your retropie script?

    Maybe run with the 2.4.2 image?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85525
    Profile photo of mikaaville
    mikaaville
    Participant

    I just don’t want to mess up anything that would make the controller not work. lol, I was being paranoid with updating.

    #85526
    Profile photo of Floob
    Floob
    Moderator

    Feel free to check out my other videos (link in signature) to see how to easily setup USB controllers.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85533
    Profile photo of mikaaville
    mikaaville
    Participant

    So, I pressed option 2 to enable the hotkeys, I made sure the ALT was set for the keyboard, I put input_enable_hotkey_btn = “9” in my controller config file and it is still escaping on a X button press. 🙁

    #85603
    Profile photo of Floob
    Floob
    Moderator

    Could you post your controller file and /opt/retropie/configs/all/retroarch.cfg file here as attachments?

    You would need to rename them .txt

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85622
    Profile photo of mikaaville
    mikaaville
    Participant

    There you go. Thanks for trying to help me!

    #85632
    Profile photo of Roo
    Roo
    Participant

    Those files are incomplete. If you’re going to log it from the Pi, try cat /opt/retropie/configs/all/retroarch.cfg instead of nano

    #85633
    Profile photo of mikaaville
    mikaaville
    Participant

    This work?

    Attachments:
    1. fromterm.txt
    #85711
    Profile photo of Floob
    Floob
    Moderator

    Yep thats better. That file looks ok to be honest.
    Can you do your controller file in the same way?

    It should be
    cat /opt/retropie/emulators/RetroArch/configs/USBconfig.cfg
    and
    cat /opt/retropie/configs/{the system you are using}/retroarch.cfg

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85716
    Profile photo of mikaaville
    mikaaville
    Participant

    There you go. 🙂

    #85724
    Profile photo of Floob
    Floob
    Moderator

    This bit looks really screwed in your USBconfig.cfg file

    input_enable_hotkey_btn = “9”
    input_exit_emulator_btn = “8”
    input_save_state_btn = “4”
    input_load_state_btn = “5”

    My first thought is that you havent used the correct ” symbol – try copying it from one of the other lines.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85727
    Profile photo of mikaaville
    mikaaville
    Participant

    That was it! as soon as I typed it out using the other symbols it worked! thanks so much!

Viewing 15 posts - 1 through 15 (of 15 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar