errors saving gamelist.xml

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 4 voices, and was last updated by Profile photo of InsecureSpike InsecureSpike 2 years, 2 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #88123
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    guys whenever i exit emulation station All of my gamelist.xml return errors,
    i have a custom es_systems.cfg [re ordered list], but even when i use my stock back up i still get these issues..

    lvl10: Error saving gamelist.xml to ""/home/pi/.emulationstation/gamelists/[then system name folder]/gamelist.xml""
    
    lvl10: Error saving gamelist.xml to ""/home/pi/RetroPie/roms[then system name folder]/gamelist.xml""

    but they all work perfectly in emulation station
    anyone else suffer with this?

    • This topic was modified 2 years, 2 months ago by Profile photo of InsecureSpike InsecureSpike.

    #88126
    Profile photo of assault
    assault
    Participant

    I would first check the permissions of the file

    ls -lah

    Some Time ago i had some similar problem and solved it with deleting the file manually and rescrapping

    #88129
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok, thanks for the reply,

    what should the permissions be?

    if the permissions are wrong, is there no way of edition them to correct them?

    • This reply was modified 2 years, 2 months ago by Profile photo of InsecureSpike InsecureSpike.
    #88131
    Profile photo of labelwhore
    labelwhore
    Participant

    Since I don’t plan on having my PI connected to the internet once everything is up and running correctly, I just go for broke and set permissions to 777 on anything I’ve needed to edit.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #88136
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok, so what command do I need to set the rom folder home/pi/RetroPi/roms to 777?

    thanks in advance

    #88138
    Profile photo of labelwhore
    labelwhore
    Participant

    sudo chmod 777 -R /home/pi/Retropie/roms

    for specific files, just remove the -R and add the filename to the end of the path. The -R sets permissions on all the files and subfolders under that folder specified including permissions of the top level folder.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 2 years, 2 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 2 years, 2 months ago by Profile photo of labelwhore labelwhore.
    #88142
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    that’s awesome! thanks fella! I’ll try this when I get home

    #88171
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    oh no!
    i did..
    sudo chmod 777 -R /home/pi/Retropie/roms

    and it sent my boot up into an “emulation station boot screen” loop lol

    • This reply was modified 2 years, 2 months ago by Profile photo of InsecureSpike InsecureSpike.
    #88175
    Profile photo of assault
    assault
    Participant

    mhh… this shouldn’t happen….

    my permission is

    -rw-r–r– 1 pi pi 22615 Jan 20 21:25 gamelist.xml

    put the sd-card into your linux pc and just change back…
    the dir permission should be

    rwxr-xr-x 2 pi pi 4096 Jan 21 23:19 .

    sudo chmod 755 -R /home/pi/Retropie/roms

    roms and files can be
    rwxrwxrwx 1 pi pi 524800 Apr 9 2005 *.smc
    (*.smc file ending of the rom)

    so just
    sudo chmod 777 /home/pi/Retropie/roms/*.smc

    #88176
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    no probs, i’m starting with a clean install and ill go from there

    thanks for the help guys

    #88177
    Profile photo of buzz
    buzz
    Keymaster

    chmodding to 777 is not correct. That will make everything world read/writable and set the executable flag.

    
    chown -R pi:pi ~/RetroPie/roms/
    

    to make sure all roms are writable by the pi user.

    
    chown -R pi:pi ~/.emulationstation/
    

    to make sure pi user can write the gameslists etc.

    #88178
    Profile photo of buzz
    buzz
    Keymaster

    of course none of this should be needed. ~/.emulationstation can get the wrong permissions if emulationstation is run via sudo though.

    #88195
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    awesome thanks, buzz

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar