Enable analogue sticks in all games?

Home Forums RetroPie Project Controller Configuration in RetroPie Enable analogue sticks in all games?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of dkcdocdos dkcdocdos 1 year, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #100092
    Profile photo of narp
    narp
    Participant

    Is there anyway to set the config so that the analogue sticks on the ps3 controller work for all games? Or at least all psx games would be good. Thanks for any advice! As it is now, i think i’ll have to do it for each game which sucks.

    #100125
    Profile photo of dkcdocdos
    dkcdocdos
    Participant

    try this (for psx):

    open

    /opt/retropie/configs/all/retroarch-core-options.cfg

    change

    pcsx_rearmed_pad1type = “standard”
    pcsx_rearmed_pad2type = “standard”

    to

    pcsx_rearmed_pad1type = “analog”
    pcsx_rearmed_pad2type = “analog”

    #100135
    Profile photo of narp
    narp
    Participant

    I added in the lines and it worked, thanks! However, there are a couple games that just dont work. For example, crash bandicoot and metal slug x just wont recognize buttons without the d pad. Can I somehow enable it for those games?

    • This reply was modified 1 year, 10 months ago by Profile photo of narp narp.
    • This reply was modified 1 year, 10 months ago by Profile photo of narp narp.
    #100203
    Profile photo of Floob
    Floob
    Moderator

    You could try this:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100377
    Profile photo of dkcdocdos
    dkcdocdos
    Participant

    I have the same problem (using an xbox360 controller); some psx games can’t be run with analog sticks, dpad works sluggy or not at all:

    You can switch the modes ingame, using a toogle button on your controller (you have to set one before) + F1. It opens RetroArch’s menu (see my linked thread, there’s a video); but it’s quite a nag changing it everytime.

    A sort of launch option would be cool…

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar