Enable analog sticks for psx within retropie setup

Home Forums RetroPie Project Ideas for Further Enhancements Enable analog sticks for psx within retropie setup

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 10 replies, has 8 voices, and was last updated by Profile photo of flowlance flowlance 1 year, 2 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #93141
    Profile photo of pattaboy
    pattaboy
    Participant

    I think it will be handy to enable or disable analog sticks for psx emulators within retropie-setup.

    Right now in 3.0 I have problems setting them up.
    Normally I only had to configure retro-arch-coreoptions and then it works.
    right now they don’t. still haven’t figured it out

    #102410
    Profile photo of padraigdoran
    padraigdoran
    Participant

    I’m on 3 rc 1 and the analogue sticks don’t work anywhere in emulationstation. It’s strange though, they did get picked up when initially configuring the gamepads.

    #102615
    Profile photo of padraigdoran
    padraigdoran
    Participant

    After reading around and doing some testing based on what I read, I did the following to get them working:

    Edit this file:
    /opt/retropie/configs/all/retroarch.cfg

    Set
    input_libretro_device_p1 = “5”
    where p1 above is the player number, like p1, p2, etc

    and set
    input_player1_analog_dpad_mode = “1”
    for each player also.

    Restart and that will allow the analog sticks to work in the games. It doesn’t work in emulationstation for some reason but that is not such a big deal.

    #108258
    Profile photo of smaikel
    smaikel
    Participant

    Yes! this is working. But I would like to know what is

    input_player1_analog_dpad_mode = “1”

    corresponding to in RGUI.

    #108538
    Profile photo of adid4s
    adid4s
    Participant

    Will doing this disable the dpad?

    #110488
    Profile photo of tandreasen
    tandreasen
    Participant

    where can i find input_player1_analog_dpad_mode…`?

    #111648
    Profile photo of dlux
    dlux
    Participant

    analog sticks working, but not in an analog fashion..

    as per padraigdoran, when i Edit this file:
    /opt/retropie/configs/all/retroarch.cfg

    and i set:
    input_libretro_device_p1 = “5”

    and i add:
    input_player1_analog_dpad_mode = “1”

    after restarting emulationstation, the sticks work, but they’re digital; i.e. in driver 2 and gran turismo 2, both games that really oughtta support the analog sticks, you’re either turning hard or going straight.. there’s no turning slightly/gently vs. a hard turn (analog action)..

    looking for further advice…

    #111649
    Profile photo of dlux
    dlux
    Participant

    and no, doing this does not disable the dpad.

    #114344
    Profile photo of eyepie
    eyepie
    Participant

    I’m in the same boat, I managed to get the analog sticks to ‘work’… but only with digital functionality. I can’t seem to figure out how to make them actually function as analog sticks.

    #117708
    Profile photo of flowlance
    flowlance
    Participant

    Any news to this? I’m using a NES30 Pro controller and the analog sticks are digital on the psx emulator, either on or off. Nothing in between. They work on the n64 emulator though.

    #117950
    Profile photo of flowlance
    flowlance
    Participant

    After googling to the end of the universe and back, i found a solution that worked for me.

    Make these changes

    pcsx_rearmed_pad1type = "analog"
    pcsx_rearmed_pad2type = "analog"

    to

    /opt/retropie/configs/all/retroarch-core-options.cfg

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar