Emulationstation overscan

Home Forums RetroPie Project Video Output on RetroPie Emulationstation overscan

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 27 replies, has 4 voices, and was last updated by Profile photo of maestroni maestroni 1 year, 7 months ago.

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #105280
    Profile photo of atimmins
    atimmins
    Participant

    I have run into an overscan problem. I set the overscan values in the /boot/config.txt file which works great for command line, but it seems that Emulationstation is ignoring these values. Once Emulationstation loads, the image goes off the screen and I can’t see the menu on the bottom. All the emulators also seem to have this problem. Has anyone else experienced this? Is there a way to adjust overscan settings for Emulationstation and emulators? I have tried copying my overscan settings to the retroarch.cfg file or individual emulator config files and it has no effect. I am running version 3.0, but also had this problem with version 2.4. It seems that this problem appeared as soon as I got lirc running, since I have kodi installed in the ports section and wanted to control it with an IR remote control.

    #105284
    Profile photo of buzz
    buzz
    Keymaster

    Have you tried adjusting the overscan options in /boot/config.txt ?

    [edit] sorry misread – but have you tried all the overscan settings – including overscan_scale ?

    • This reply was modified 1 year, 8 months ago by Profile photo of buzz buzz.
    #105287
    Profile photo of atimmins
    atimmins
    Participant

    I tried adding the following lines without success:

    overscan_left=23
    overscan_right=-20
    overscan_top=-20
    overscan_bottom=-10
    overscan_scale=1

    #105289
    Profile photo of dankcushions
    dankcushions
    Participant

    i had the same issue with overscan in the ES menu, and changing the boot/config.txt fixed it for me, so i can confirm that ES respects the values (i think it has to, as they’re set at a system level). i’ll try and remember to dump my boot/config.txt here tonight.

    • This reply was modified 1 year, 8 months ago by Profile photo of dankcushions dankcushions.
    #105290
    Profile photo of buzz
    buzz
    Keymaster

    What display do you have ? how is it connected? does changing videomode in config.txt help ?

    Make sure you have tested both with and without overscan_scale – and also try disable_overscan=1

    #105302
    Profile photo of atimmins
    atimmins
    Participant

    It is hooked up to a 65″ mitsubishi DLP TV with HDMI. I have tried 480p and 1080p hdmi modes and haven’t noticed any change. Would installing lirc have anything to do with this? I can’t imagine that it would, but it was weird that the problem only showed up after getting lirc running. I also noticed overscan in Kodi (xbmc) right after lirc started working. That was easy enough to fix with video calibration settings in Kodi though.

    I have also tried modifying the full screen settings in the retroarch.conf file like this:

    video_fullscreen_x = 0
    video_fullscreen_y = 0

    Supposedly this is supposed to force it to use the desktop resolution, but it doesn’t make any difference.

    • This reply was modified 1 year, 8 months ago by Profile photo of atimmins atimmins.
    #105329
    Profile photo of buzz
    buzz
    Keymaster

    I can’t think lirc is related, unles something adjusted the config.txt for the system – maybe you have some conflicting settings in config.txt ? Perhaps you can paste it via pastebin or similar.

    or start with a fresh retropie image – and if that works, compare the configs ?

    #105357
    Profile photo of atimmins
    atimmins
    Participant

    I don’t think the /boot/config.txt file has been changed by lirc. What is really bothering me is that the overscan problem is only within Emulationstation and individual emulators. The command line interface shows up fine and follows the overscan settings in the config.txt file. The RetroPie splashscreen and Emulationstation loading screens look fine, but once Emulationstation opens up, I can’t see the entire screen. I had this problem previously with RetroPie version 2.4. I did a fresh install of version 3.0 and things looked fine until lirc started working. Now it is behaving exactly like it did previously.

    #105362
    Profile photo of buzz
    buzz
    Keymaster

    afair overscan_left / right etc won’t affect ES, just the framebuffer – but usually overscan_scale=1 solves problems of it being offscreen – you said you have tried that so im out of ideas. You didn’t post your config.txt though.

    #105364
    Profile photo of buzz
    buzz
    Keymaster

    Also see if there are any settings on your screen you can tweak in reagrds to display size/zoom. Also check settings here – http://elinux.org/RPiconfig (maybe trying other other modes / hdmi safe mode etc)

    #105375
    Profile photo of maestroni
    maestroni
    Participant

    I’ve been searching the internet for a solution for this issue. I’m running a HDTV in portrait mode and the command line all the roms show up with the overscan settings from my config.txt file but emulation station does not recognize these settings.
    Is it possible (if these files exist) to add overscan settings to /etc/emulationstation/es_systems.cfg or~/.emulationstation/es_systems.cfg

    Attachments:
    #105378
    Profile photo of buzz
    buzz
    Keymaster

    ES has no overscan settings of its own. It has some resolution parameters

    See https://github.com/Aloshi/EmulationStation/issues/416

    #105379
    Profile photo of buzz
    buzz
    Keymaster

    the resolution parameter might help the original poster too perhaps.

    #105430
    Profile photo of maestroni
    maestroni
    Participant

    Thanks for the tip

    I tried to modify the file under /opt/retropie/supplementary/emulationstation/emulationstation like the link above mentions but the file is a bunch of illegible symbols.

    I was using the sudo nano command and a message appears at the bottom of the screen that reads “converted from DOS and MAC format.

    #105435
    Profile photo of dankcushions
    dankcushions
    Participant

    afair overscan_left / right etc won’t affect ES, just the framebuffer – but usually overscan_scale=1 solves problems of it being offscreen – you said you have tried that so im out of ideas. You didn’t post your config.txt though.

    overscan_left / right etc for sure affect ES – I also had overscan issues in ES (the menu button icons ran over the edge of the screen) and used these settings to sort out my overscan – I had to be right up to the screen to get the pixel-perfect settings 🙂 here’s my config.txt:

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    overscan_left=24
    overscan_right=24
    overscan_top=24
    overscan_bottom=24
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # for more options see http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    
    overscan_scale=1
    
    # overclock settings
    arm_freq=1000
    over_voltage=0
    core_freq=500
    sdram_freq=483
    over_voltage_sdram_p=0
    over_voltage_sdram_i=0
    over_voltage_sdram_c=0
    gpu_mem=256
    #105628
    Profile photo of atimmins
    atimmins
    Participant

    I tried working on this over the weekend. I tried adjusting the frame buffer values and tried disabling overscan without success. I found that removing the line “overscan_scale=1” from my config.txt file helped a little bit. Now I can see about half of the emulationstation menu. It seems like adding this line is the only thing that has helped everyone else, so I am out of ideas.

    #105629
    Profile photo of buzz
    buzz
    Keymaster

    overscan_left / right etc for sure affect ES – I also had overscan issues in ES (the menu button icons ran over the edge of the screen) and used these settings to sort out my overscan – I had to be right up to the screen to get the pixel-perfect settings :) here’s my config.txt:

    Yeh sorry, I should have said, they don’t affect emulationstation unless overscan_scale is set – or at least that’s what I remember reading.

    #105631
    Profile photo of atimmins
    atimmins
    Participant

    My overscan_scale was set to 1 from the beginning and emulationstation refused to honor the overscan settings. Removing the overscan_scale line was the only thing that gave any marginal improvement.

    #105632
    Profile photo of dankcushions
    dankcushions
    Participant

    I tried working on this over the weekend. I tried adjusting the frame buffer values and tried disabling overscan without success. I found that removing the line “overscan_scale=1″ from my config.txt file helped a little bit. Now I can see about half of the emulationstation menu. It seems like adding this line is the only thing that has helped everyone else, so I am out of ideas.

    you need to add overscan_scale=1 in conjunction with the various overscan_left/etc settings. your settings from above:

    overscan_left=23
    overscan_right=-20
    overscan_top=-20
    overscan_bottom=-10
    overscan_scale=1

    if ES is running OVER the edge of the screen, you should be using positive numbers. negative numbers exacerbate the problem – they’re for when you have a black border around ES. so it makes sense to me that if you remove overscan_scale=1, you see more, assuming you’re still using the above set up.

    try:
    overscan_scale=1
    overscan_bottom=20 (rather than -10)

    if that works i’d probably do the same with the other overscan_’s – you’ll probably find they all need the same number.

    • This reply was modified 1 year, 7 months ago by Profile photo of dankcushions dankcushions.
    #105637
    Profile photo of atimmins
    atimmins
    Participant

    I tried working on this over the weekend. I tried adjusting the frame buffer values and tried disabling overscan without success. I found that removing the line “overscan_scale=1″ from my config.txt file helped a little bit. Now I can see about half of the emulationstation menu. It seems like adding this line is the only thing that has helped everyone else, so I am out of ideas.

    you need to add overscan_scale=1 in conjunction with the various overscan_left/etc settings. your settings from above:

    overscan_left=23
    overscan_right=-20
    overscan_top=-20
    overscan_bottom=-10
    overscan_scale=1

    if ES is running OVER the edge of the screen, you should be using positive numbers. negative numbers exacerbate the problem – they’re for when you have a black border around ES. so it makes sense to me that if you remove overscan_scale=1, you see more, assuming you’re still using the above set up.

    try:
    overscan_scale=1
    overscan_bottom=20 (rather than -10)

    if that works i’d probably do the same with the other overscan_’s – you’ll probably find they all need the same number.

    The config file you quoted isn’t mine. It was posted by someone else. As I mentioned in my last two posts, I have already tried overscan_scale=1 in conjunction with overscan left, right, etc values and it makes no difference. In my particular setup, overscan_scale=1 seems to make the problem worse. Removing that line allowed me to see a little more of the screen, but I still have an overscan problem.

    #105639
    Profile photo of dankcushions
    dankcushions
    Participant

    The config file you quoted isn’t mine. It was posted by someone else.

    i copied it from your second post…

    I tried adding the following lines without success:

    overscan_left=23
    overscan_right=-20
    overscan_top=-20
    overscan_bottom=-10
    overscan_scale=1

    #105642
    Profile photo of atimmins
    atimmins
    Participant

    Okay, two questions. First, are you saying that I need the overscan_scale=1 line four times, one for each overscan value (top, bottom, left, right)? Second, if I change the overscan values to correct emulationstation, am I doing at the expense of having correct overscan values for the command line interface? The values I originally posted are what work for my TV to get the correct screen size for command line. I figured that since I was able to see all of the command line image without borders then emulationstation should work the same. Obviously that isn’t true.

    #105646
    Profile photo of buzz
    buzz
    Keymaster

    Just once.

    All I can say is with my setup, using overscan_scale=1, the framebuffer and emulationstation use the same overscan settings. Without the line, only the console is affected, and emulationstation ignores the settings.

    Not sure why it would be different on yours – please post your config – and as pointed out, you need positive numbers to decrease the overscan / add a border.

    #105649
    Profile photo of dankcushions
    dankcushions
    Participant

    so you previously adjusted the overscan to get the command line text flush with the edge of the screen? I’m not so sure that’s how it should be. i think a small buffer border is intentional.

    you need to set overscan to match something that renders to the edge of the screen – eg ES.

    #105675
    Profile photo of atimmins
    atimmins
    Participant

    I have been working on this tonight and wanted to say that you guys were right and I was wrong. Adjusting the overscan values and adding overscan_scale=1 seems to have fixed my problem. It seems that in my ignorance of raspberry pi and Linux that I set my initial overscan settings incorrectly. I assumed that I was supposed to make the command line text flush with the edges of the screen. I can see now this was incorrect. Thank you all for your suggestions and help.

    #105759
    Profile photo of maestroni
    maestroni
    Participant

    Hello,

    I tried the above and my emulationstation still does not fit the screen. My setup is a little different in that I have a 16:9 HDTV screen rotated to fit in an arcade cabinet. I attached a picture on 9/3.
    I originally thought ES was not recognizing the default overscan settings, but I think it is not recognizing my frame_buffer_width/height settings. The rest of the system fits on a 4:3 screen and with the overscan settings. My retropie files seemed to be the latest but I updated them just in case.

    Any ideas?

    Here is my /boot/config.txt

    # uncomment if you get no picture on HDMI for a default “safe” mode
    #hdmi_safe=1
    display_rotate=3
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=0

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=24
    #overscan_right=24
    overscan_top=50
    overscan_bottom=-50
    overscan_scale=1
    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.
    framebuffer_width=640
    framebuffer_height=480

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    # for more options see http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256

    #105781
    Profile photo of buzz
    buzz
    Keymaster

    did you try passing the width / height resolution parameter to emulationstation as mentioned earlier ?

    #105813
    Profile photo of maestroni
    maestroni
    Participant

    Thanks for the response but I’m not quite sure how to pass the resolution parameters to emulationstation.

    Do you mean do what the post on 9/02 said:

    “settings in the retroarch.conf file like this:
    video_fullscreen_x = 0
    video_fullscreen_y = 0”

    Or the post on 9/03 which had the link and the entry below at the link.

    “https://github.com/Aloshi/EmulationStation/issues/416
    I believe what is happening here is that part of the scraping UI is trying to resize to a negative width because there simply isn’t enough horizontal space for it. You could probably just comment out that line in ComponentGrid.cpp to make it not abort, but it will definitely look funny.”

Viewing 28 posts - 1 through 28 (of 28 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar