editing retroarch.cfg from /opt/retropie/configs/all doesnt do anyhthing

Home Forums RetroPie Project Everything else related to the RetroPie Project editing retroarch.cfg from /opt/retropie/configs/all doesnt do anyhthing

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #83869
    Profile photo of pcloadletter
    pcloadletter
    Participant

    new to the Forum so I’m sorry if I’m posting in the wrong spot. did a quick search and can’t seem to find my exact problem.

    So here is my problem, I have the Xarcade tank stick (with trackball). i downloaded and imaged an 8gb SD card with the 2.3 image. set up my language options, keyboard options for the US. dropped some roms in for MAME, SNES, NES.
    editied what i thought i needed to in /opt/retropie/configs/all retroarch.cfg under the keyboard settings adding things like:
    input_player1_a = z
    input_player2_down = f
    etc.
    MAME is working flawlessly, even the trackball works in bowling games, but I know its not reading the cfg file from that location because I just changed the inputs, for player one, for up and down and reversed them (ex. input_player1_up = down). rebooted no effect, added input_exit_emulator_btn = 3 and nothing. I’m thinking its not reading the retroarch.cfg from that location and wondering if there is somewhere else I should be editing it.

    I did some reading and looked in /home/pi/RetroPie/ but there is no config folder here. i tired creating one then an all folder and dropping the retroarch.cfg there and still no change

    The bigger problem is that NES and SNES don’t respond at all except to the left joystick.

    I even went as far as re-imaging with 2.3 and setting it all back up, going into /opt/retropie/configs/all and still the same issue.

    I’m not much of a Linux user but I’m very capable in the windows environment so please be a little patient with me.

    #83874
    Profile photo of Floob
    Floob
    Moderator

    Mame uses its own config file (for controllers etc..)
    SNES/NES etc.. use retroarch.cfg

    This may help:
    http://blog.petrockblock.com/2014/06/01/xarcade2jstick/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    • This reply was modified 2 years, 4 months ago by Profile photo of Floob Floob.
    • This reply was modified 2 years, 4 months ago by Profile photo of Floob Floob.
    #83889
    Profile photo of pcloadletter
    pcloadletter
    Participant

    deleted

    • This reply was modified 2 years, 4 months ago by Profile photo of pcloadletter pcloadletter.
    #83892
    Profile photo of pcloadletter
    pcloadletter
    Participant

    Thanks for the quick reply, I think i have it working somewhat the way i need it to now.
    installed Xarcade2Jstick, registered as a service etc from the link you provided and opened the MAME emulator hit TAB and remapped all the controls.

    the only issue is the one button in the nes emulator exits the game and i would like to remap just that one is there a button similar to TAB for mame that lets me into the emulator menu for the NES emulator that comes with retropie?

    #83893
    Profile photo of Floob
    Floob
    Moderator

    You can have system specific configs for retroarch based emulators
    /opt/retropie/configs/{systemname}/retroarch.cfg

    That will overwrite values set in the /all/retroarch.cfg file

    Also if you uncomment this, you can get a GUI in retroarch emulation

    # Toggles menu.
    # input_menu_toggle = f1

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83895
    Profile photo of pcloadletter
    pcloadletter
    Participant

    Thanks again for the quick reply, my issue in NES was that I had set a hotkey and and exit key in the /opt/retropie/configs/nes. removed those and its working. only thing left is to set a key to exit the emulator for NES SNES and Genesis. I’d like to use what the joypad config sees as “8” so i put in input_exit_emulator_btn = 8 and input_enable_hotkey_btn = 8 but it doesnt seem to do anything

    #83919
    Profile photo of laoracc
    laoracc
    Participant

    Try putting the 8 in quotes, and change the enable hotkey button to something else. I don’t know if your setup would work, ie – hotkey + functionality on the same button, but it would almost certainly prevent you from mapping any other hotkey functionality (like menu/save/load/etc).

    #83920
    Profile photo of Floob
    Floob
    Moderator

    Yes, as laoracc says, try one button for the hotkey, and another for the action.
    Here is an example:
    http://blog.petrockblock.com/wp-content/uploads/2014/12/USB2-axis8-buttongamepad.txt

    So:
    input_enable_hotkey_btn = “6”

    is the hotkey, and everything below that is a hotkey based action.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar