Duke Nukem 3D Emulator

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of fonzman fonzman 2 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1450
    Profile photo of skater_j10
    skater_j10
    Participant

    Repost from the Raspi Forums since the question will likely get buried there.

    Anyone have a tutorial on a legit installation of this game with RetroPie, from purchasing the game from 3D Realms http://www.3drealms.com/duke3d/index.html (or using the shareware version) to getting the files placed in the correct RetroPie/RetroArch folders? I’ve been up and down the forums and even resorted to googling…couldn’t seem to get it going.

    #1464
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I used gog.com for buying “Duke Nukem 3d: Atomic Edition”. For some reasons, 3drealms.com showed problems during the payment process in my case.

    The Windows installation contains a file “DUKE3D.GRP”. This file has to be copied into the directory

    /home/pi/RetroPie/roms/duke3d

     To be able to start Duke3D, you also need to have educed installed. If it is not already installed, you can do this by starting the RetroPie Setup Script, choose “source-based installation” and de-select everything except Duke3D.

    I hope that helps!?

    #1466
    Profile photo of skater_j10
    skater_j10
    Participant

    Thank you petrockblog,  I had the same issue with the 3Drealms site, had to download via gog.com as well.

    So I moved DUKE3D.GRP to my roms folder but it didn’t work but I tried what you suggested and reinstalled eduke32 with the “source based installation” and it worked!

    So sweet, thanks again. My only comments now are: unfortunately it seems unplayable for me as it’s strictly keyboard/mouse controls not joystick and it doesn’t display through the composite (RCA) jack only the HDMI, so sad.

    #1468
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Glad to hear that!

    Did you already have a look at http://wiki.eduke32.com/wiki/Joystick_setup for the joystick issue?

    #1471
    Profile photo of skater_j10
    skater_j10
    Participant

    Sweet, I didn’t know that existed, thanks for that! Now if only there was a solution for RCA out… Maybe I should try some different video scaling values in retroarch.cfg.

    #49505
    Profile photo of fonzman
    fonzman
    Participant

    Can’t get my joypad to work with the Duke.

    you must check the joystick check-box under the configuration tab of the Eduke32 pre-game setup

    funny .. where exactly is this “configuration tab … pre-game setup”?!? Has anyone a step-by-step guide how to enable the joystick in eduke32?

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar