DS3 bluetooth not working on Retroarch

Home Forums RetroPie Project Controller Configuration in RetroPie DS3 bluetooth not working on Retroarch

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of mayki mayki 1 year, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #105323
    Profile photo of sweden38
    sweden38
    Participant

    Hello all,
    This is my first post, and I have tried to find out a solution reading differnt forums but I have not found the answer.
    The problem that I have is that my DS3 remote pad is working fine on EMUSTATION (on my Raspberry Pi 2), so I can navigate all over the menus wireless with the DS3 pad, but as soon as I launch a game/ROM (on any given emulator; Snes, Amiga,Atari, Nintendo…) retroarch (3.0 version) is only lisenning to my keyboard, the DS3 is useless.

    I´m probably forgetting a very simple step or configuration (I have set up the retroarch.cfg wiresly UP/DOWN/…), but nothing else.
    Looking to tutorials on YOUTUBE, looks like it should have to work almost strait away once retroarch.cfg is set so.. What step am I missing?.

    I´m really a beginner with Raspberry, so please be patient with me.

    BR

    Sweden38

    #105380
    Profile photo of mayki
    mayki
    Participant

    I have the same problem, I installed the new version RetroPie_OpenELEC_Dual-Boot_v7_SS, I proceeded according to this video http://blog.petrockblock.com/forums/topic/video-guide-for-ps3-wireless-controller-on-retropie-3-final/ but my PS3 gamepad works only in the menu, does not in any ROM (Megadrive, PSX, Nintendo) is not working. The previous installation Retropie 3.0 RC everything worked OK.

    #105381
    Profile photo of buzz
    buzz
    Keymaster

    what do you have in /opt/retropie/configs/all/retroarch-joypads/ ?

    #105382
    Profile photo of mayki
    mayki
    Participant

    PLAYSTATION(R)3Controller.cfg

    input_device = "PLAYSTATION(R)3 Controller"
    input_driver = "udev"
    input_b_btn = "14"
    input_y_btn = "15"
    input_select_btn = "0"
    input_start_btn = "3"
    input_up_btn = "4"
    input_down_btn = "6"
    input_left_btn = "7"
    input_right_btn = "5"
    input_a_btn = "13"
    input_x_btn = "12"
    input_l_btn = "10"
    input_r_btn = "11"
    input_l2_btn = "8"
    input_r2_btn = "9"
    input_l3_btn = "1"
    input_r3_btn = "2"
    input_l_x_plus_axis = "+0"
    input_l_x_minus_axis = "-0"
    input_l_y_plus_axis = "+1"
    input_l_y_minus_axis = "-1"
    input_r_x_plus_axis = "+2"
    input_r_x_minus_axis = "-2"
    input_r_y_plus_axis = "+3"
    input_r_y_minus_axis = "-3"
    input_enable_hotkey_btn = "0"
    input_exit_emulator_btn = "3"
    input_menu_toggle_btn = "12"
    input_load_state_btn = "10"
    input_save_state_btn = "11"
    input_reset_btn = "14"
    input_state_slot_increase_btn = "5"
    input_state_slot_decrease_btn = "7"

    EDIT: Problem solved
    http://blog.petrockblock.com/forums/topic/retropie-openelec-kodi-dual-boot/page/7/

    • This reply was modified 1 year, 7 months ago by Profile photo of mayki mayki.
    • This reply was modified 1 year, 7 months ago by Profile photo of mayki mayki.
Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar