DosBox help please

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.


This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of luckylocky luckylocky 1 year, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #109138
    Profile photo of luckylocky

    I’m trying to run a game dos game through retropie 3.1 but need help. I have dowloaded dos box onto my pc to test the game and it works fine on there so i know the game is good. How do I get this to work on my retropie? I have tried to follow the instructions in the link but i get to the point
    I entered the command

    “cd /opt/retropie/emulators/dosbox/bin”

    and got into the directory then i typed the command


    and got -bash: dosbox: command not found

    What am i doing wrong please? really would love to get this working

    Profile photo of ronoh55

    Try ./dosbox

    Sometimes (idk why because I’m still relatively new to linux still) it needs to be told to look in that directory for the executable file.

    Profile photo of luckylocky

    Thanks ronoh55 that worked! you the man. So i was able to play my game gtf (good to firm) in the dosbox emulator. But i am still stuck how to launch it from ES. I have followed the instructions

    run the following commands.

    cd ~/RetroPie/roms/pc
    sudo nano

    Copy and paste the code below.

    /opt/retropie/emulators/dosbox/bin/dosbox -c “mount c /home/pi/RetroPie/roms/pc” -c “c:” -c “cd gtf” -c “GTF.EXE” -c “exit”

    Save and exit. Next make the executable so it can be launched from emulationstation.

    sudo chmod +x

    when i type this last line ^ and press enter is it suppose to say anything? mine just goes to the next line ready to type command again.

    so the GTF folder now shows up in my IBM folder but when i try ;aunch i get an error that is the usual oe when roms dont work. im so close 🙂 at least i can play it but pain in the but having to mount everytime. This would be so awesome if I could get launching from ES.
    Thanks for any help

    Profile photo of luckylocky

    all good its solved. I reinstalled binaries which put the startdosbox Which i had deleted) back in emulator folder. it worked when i clicked on gtf then 🙂

    cheers for help

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar