Disabling the option screen as the EMU loads and exits

Home Forums RetroPie Project Everything else related to the RetroPie Project Disabling the option screen as the EMU loads and exits

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 5 voices, and was last updated by Profile photo of buzz buzz 1 year, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #103080
    Profile photo of michaelc1985
    michaelc1985
    Participant

    Hello all

    I was wondering if their is a way to disable the splash screen as you start and exit a EMU.

    i keep entering the menu.

    Thanks

    Michael

    #103084
    Profile photo of robertybob
    robertybob
    Participant

    The one which asks whether you want to configure an emulator? (m or x?)

    #103087
    Profile photo of herbfargus
    herbfargus
    Moderator

    This is the only thing I can think of off the top of my head short of hard coding configs without runcommand in emulationstation:

    http://blog.petrockblock.com/forums/topic/command-line-access-toggler-for-a-cleaner-look/

    #103107
    Profile photo of
    Anonymous

    I actually discovered a very easy fix for this as i was having the same issue. My sixaxis remotes accelerometer was causing me to enter the menu screen every time i launched a game.

    go here
    opt/retropie/supplementary/runcommand

    first make a backup of runcommand.sh
    sudo cp runcommand.sh runcommand.sh.bak

    then open runcommand.sh
    sudo nano runcommand.sh

    find this line
    IFS= read -s -t 1 -N 1 key </dev/tty

    Then modify the “-N 1” to “-N 0” so it should look like the below.
    IFS= read -s -t 1 -N 0 key </dev/tty

    This will tell the script to look for 0 characters being pressed (and therefore you will never enter the menu. This will probably get overwritten when you update so you might need to modify it again.

    #103124
    Profile photo of buzz
    buzz
    Keymaster

    Alternatively you could disable the launching of the joy2key code so it would not be activated by a joypad movement/press.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar