Disable Retropie as active source over CEC

Home Forums RetroPie Project Everything else related to the RetroPie Project Disable Retropie as active source over CEC

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of ftjosas ftjosas 1 year, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #103833
    Profile photo of ftjosas
    ftjosas
    Participant

    Does anyone know how to disable that Retropie is set as active source over CEC on startup?

    I have my RPI2 with Retropie (V3.0 RC1) connected to my reciever. Whenever I turn on the TV and the reciever, the reciever automatically swithces to the HDMI channel where the Retropie is connected. This happens regardless of which HDMI channel was active last. If I switch to another HDMI channel quickly then it reverts to the Retropie channel within 10 seconds. This does not happen if I wait some seconds first though. It only happens when I start up the system, the RPI2 is always on (I never turn it off)

    This has also been a case with my other RPIB+ with OSMC. But this was solved by unchecking the “set KODI as active source when start up” in the settings menu.

    I have tried to find a way to do a similar thing in Retropie but I haven’t had any luck. I have installed the cec-utils but I am afraid my knowledge on how to use it proved too low 🙁

    I would appreciate any help on this.

    System info:
    RPI2 with Retropie V3.0 RC1
    Reciever: SONY STR-DN1040. (RPI2 connected to BD HDMI channel)
    TV: Samsung LE40B535P7W

    #103835
    Profile photo of herbfargus
    herbfargus
    Moderator

    Usually there are cec options on TVs that you can turn off.

    Or if you want to disable it on the pi itself you can Add hdmi_ignore_cec=1 to /boot/config.txt

    #103877
    Profile photo of ftjosas
    ftjosas
    Participant

    I followed your advice and put the hdmi_ignore_cec=1 in config.txt. When I turned on the TV and reciever today it stayed on the hdmi channel which was last active and it did not switch to the Retropie channel. I will give it a few more days just to be sure that the problem is solved and update here.

    Thanks 🙂 🙂

    #104037
    Profile photo of ftjosas
    ftjosas
    Participant

    The fix is still working. Thank you herbfargus for solving this problem. I’ll put this as solved.

    F

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar