custom controller config not saving

Home Forums RetroPie Project Controller Configuration in RetroPie custom controller config not saving

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of dixeflatline dixeflatline 1 year, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #101656
    Profile photo of dixeflatline
    dixeflatline
    Participant

    Before anyone bashes me for not reading the forum before posting, I have. I have read just about every controller config tut and even followed along with Floob and TechTipsta on youtube.

    My problem:
    My configs are not saving or reverting when I launch any EMU from retroarch. I have done the retroarch controller configuration and even tried obscure button combos and they dont take in the EMU. The only config working is the initial retropi menu config. I have deleved all configs multiple times from /opt/retropie/configs/all/(controller) cant remember off the top of my head the last folder for retro joypad configs but you get the picture. I was thinking maybe I would need to reflash retropie and start from scratch but I wanted to hear from the pros first.

    2nd, when launching the retroarch controller config, it only asks for buttons X, B, Y, A, and L/R shoulder top/bottom plus D-Pad and left/right axis. If I wanted to config a Sega Saturn type 6 button + shoulder how would I add the other 2 buttons? Would I have to manually enable input for button “x” in the config file?

    Thank you everyone and thank you to all the devs. Keep up the amazing work!

    DFL

    #101692
    Profile photo of dixeflatline
    dixeflatline
    Participant

    I think I have this resolved. I formatted the SDcard and re-imaged RetroPie 3 b4. I ran through all the normal configurations and then set up controllers. They are now mapped correctly.

    Though my 2nd question is still present. If I have a sega 6 button like controller + 2 bumbers, do I need to manually configure the 2 not listed if the controller script?

    Thanks,
    DFL

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar