Controllers not working in ROMS

Home Forums RetroPie Project New to RetroPie? Start Here! Controllers not working in ROMS

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of sparky3903 sparky3903 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #106810
    Profile photo of sparky3903
    sparky3903
    Participant

    Hey, I am very, very new to RetroPie. First off, I think its awesome, my boys are going to love it. I have it setup on the pi 2 and the controller is working great in the UI. I can go through all the different emulators and such. I added a bunch of ROMs for SNES and for Genesis. Once I select the ROM and it boots up my controllers stop working. I can’t do anything but pull the plug on the pi 2 and reboot it.

    Any help would be great.

    Sparky

    #106811
    Profile photo of herbfargus
    herbfargus
    Moderator

    Without more details its hard for people to know how to help.

    http://blog.petrockblock.com/forums/topic/suggestion-to-get-support-with-your-problems/

    Which controller(s) are you using? Which version of retropie?

    #106829
    Profile photo of sparky3903
    sparky3903
    Participant

    Sorry, I installed version 3 and I am trying Logitech gamepad F310. It works great in the UI itself and in the emulators of the games that came with the install. I added in Super Mario 3 for my kids under the NES in the roms section. It shows up in the UI now to play but the controller doesn’t work. Same with one in the genesis and one in the N64. Seems like anything I have added isn’t working.

    Thanks.

    #106833
    Profile photo of herbfargus
    herbfargus
    Moderator

    I don’t know how to fix that as I don’t have that controller. But some others seem to have gotten it to work:

    https://m.reddit.com/r/RetroPie/comments/2r6geu/logitech_f310_retropie_help/

    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    #106844
    Profile photo of jbfortune
    jbfortune
    Participant

    If you go into the individual retroarch.cfg file locaterd in /opt/retropie/configs/nes and add in

    input_player1_joypad_index = 0 <—– being the number of your pad (can see this at the bottom of the screen when loading a rom)

    Save the file and try again?

    #106858
    Profile photo of sparky3903
    sparky3903
    Participant

    Awesome guys, I will try it out tonight.

    #106860
    Profile photo of herbfargus
    herbfargus
    Moderator

    if not I just ordered three of the same controller and I’ll work on it in the coming weeks once they get here

    #106883
    Profile photo of sparky3903
    sparky3903
    Participant

    Wow, great. That worked. Thanks again, awesome.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar