Controller Not Working in Game

Home Forums RetroPie Project Everything else related to the RetroPie Project Controller Not Working in Game

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 7 voices, and was last updated by Profile photo of nihlton nihlton 2 years, 4 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #5003
    Profile photo of josy-cotter
    josy-cotter
    Participant

    All. I have read quite a bit about other having this problem but i can’t seem to get my issue fixed. I have 2 USB NES controllers that work fine before launching the game. As soon as i’m in the game they do not work.

    I have a config file at /RetroPie/configs/all/retroarch.cfg and one in /RetroPie/configs/all/nes/retroarch.cfg.

    I have ran the retroarch-joyconfig script several times but no luck. What should I be looking at next?

    #5008
    Profile photo of gizmo98
    gizmo98
    Participant

    If you had already run…
    # ./retroarch-joyconfig >> ~/RetroPie/configs/all/retroarch.cfg

    …check your retroarch.cfg.

    There could be duplicates of the following settings:
    input_player1_joypad_index = 0
    input_player2_joypad_index = 1
    input_player1_b_btn = “2”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “1”
    input_player1_x_btn = “0”
    input_player1_l_btn = “6”
    input_player1_r_btn = “7”
    input_player2_b_btn = “2”
    input_player2_y_btn = “3”
    input_player2_select_btn = “8”
    input_player2_start_btn = “9”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “1”
    input_player2_x_btn = “0”
    input_player2_l_btn = “6”
    input_player2_r_btn = “7”

    Your joypad config should be at the end of the file. Disable all duplicates with “#”.

    #5009
    Profile photo of josy-cotter
    josy-cotter
    Participant

    If i have one config in the all folder and one config in the emulator specific folder, will they cause issues with each other? Or will the one in the emulator folder completely override the one in the all folder?

    Here is what I have.

    system_directory = /home/pi/RetroPie/emulatorcores/
    video_aspect_ratio = 1.33
    video_smooth = false
    input_enable_hotkey = escape
    input_exit_emulator = escape
    rewind_enable = true
    rewind_buffer_size = 10
    rewind_granularity = 2
    input_rewind = r
    input_shader_next = m
    input_shader_prev = n
    video_shader_dir = /home/pi/RetroPie/emulators/RetroArch/shader/
    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_autodetect_enable = true
    joypad_autoconfig_dir = /home/pi/RetroPie/emulators/RetroArch/configs/
    audio_driver = alsathread
    audio_out_rate = 48000
    input_player1_joypad_index = 0
    input_player1_select_btn = 8
    input_player1_start_btn = 9
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = 0
    input_player1_b_btn = 1

    #5010
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Not sure if you need quotation marks either side of the gamepad buttons, try copying and pasting this:

    input_player1_joypad_index = 0
    input_player1_select_btn = "8"
    input_player1_start_btn = "9"
    input_player1_up_axis = "-1"
    input_player1_down_axis = "+1"
    input_player1_left_axis = "-0"
    input_player1_right_axis = "+0"
    input_player1_a_btn = "0"
    input_player1_b_btn = "1"

    If you have found the solution to your problem please mark the topic as resolved.

    #5011
    Profile photo of cacophony555
    cacophony555
    Participant

    Are you allowed to define player1 for both the keyboard and gamepad? I would try commenting out all the keyboard controls.

    #5037
    Profile photo of foob
    foob
    Participant

    I could weigh in on a few things here.

    Firstly, think of the /all/ config as the “master” config. If you look at the configs in the emulator specific folders, you will notice they are mostly empty. The way this works, is that it looks at the emulator specific config first for settings, and whatever it doesn’t find, it will take from the global config. So, if you want to use one global config for everything, just set up the one in /all/ and ignore the rest.

    As for your issue, I’d say its likely you still have the keyboard keys active in the cfg as well as your joypad ones. make sure to go through all the keys under the keyboard section and put a # infront of every single one of them to disable it. I have recently uploaded my retroarch.cfg for use in a different thread so you can look at mine and compare.

    https://dl.dropboxusercontent.com/u/4436120/retroarch.cfg

    #5038
    Profile photo of foob
    foob
    Participant

    Also, i suppose at a stretch you could just try dumping my retroarch cfg in place of yours and seeing if it works. Obviously back up your old one first. It shouldnt do any harm. Likely some video settings will be different and my controller is probably configured differently to yours so the buttons are probably messed up but it should basically work.

    #5051
    Profile photo of josy-cotter
    josy-cotter
    Participant

    Thanks all for the help. That’s exactly what I was looking to clarify on with the two cry files. I wasn’t sure if one was ignored if the specific one was present. I was able to get mine to work with the global config. Now I need to make some specific ones for the different controllers I have.

    Thanks again.

    #40195

    RakaMakaFon

    Hello. I see lots of good advice here, and it seems to be solving the issue. But this is my first time using a Linux device (got my Raspberry Pi yesterday) and I have no experience at all using this. I found the terminal, but I really don’t know how to do anything here. Could you please tell me what to do, to make my controller work in game (that works in emulation mode), for a total rookie at Linux/Raspberry Pi?

    #54430

    gamecubator

    I wish I could help. I am stuck too.

    Retropie coolness put aside, I too am frustrated with the lack of clear and up to date info on the setting up of retropie for two-player games (gamepads). Hours wasted on this thus far.

    Will post info if and when found.

    #54521

    gamecubator

    Okay done, thanks to gizmo98, josy-cotter and foob.

    I had bought 2 low-cost SNES USB controllers for PC/MAC (Tomee) and wanted to play 2-player NES games with them on my retropie distro.

    Here is that part of /opt/retropie/configs/all/retroarch.cfg that configures both gamepads as well as sets up emulator exit via “start+select” buttons combo:

    input_player1_joypad_index = 0
    input_player2_joypad_index = 1

    input_player1_b_btn = “2”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “1”
    input_player1_x_btn = “0”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player2_b_btn = “2”
    input_player2_y_btn = “3”
    input_player2_select_btn = “8”
    input_player2_start_btn = “9”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “1”
    input_player2_x_btn = “0”
    input_player2_l_btn = “4”
    input_player2_r_btn = “5”

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    I hope it helps.
    Alex

    #56742
    Profile photo of apedroid
    apedroid
    Participant

    Why are you setting up your controllers in /opt/retropie/configs/all/retroarch.cfg?

    Here’s how I do it and how I believe it should be done (you can do this either through SSH from another machine or locally using a keyboard):
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    Select number 3 (Setup)
    Select number 315 (Register RetroArch controller)
    Follow the instructions

    Your controller config will now be saved in its own file in /opt/retropie/emulators/RetroArch/configs/ and it will be used only for this specific controller so you can have different mappings for different controllers.

    Sadly the hotkey, exit, load state and save state buttons seems to have to be in the main retroarch.cfg which kind of limits the possibility to mix controller types.

    #83940
    Profile photo of nihlton
    nihlton
    Participant

    @gamecubator – Dude. I registered this account just so i could say thank you. I was in the same boat (tomee usb controllers) and that totally worked. thank you so much!

    • This reply was modified 2 years, 4 months ago by Profile photo of nihlton nihlton.
Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar