Controller is always "not configured"

Home Forums RetroPie Project Controller Configuration in RetroPie Controller is always "not configured"

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 27 replies, has 13 voices, and was last updated by Profile photo of SwissPi SwissPi 1 year, 3 months ago.

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #111841
    Profile photo of proxycell
    proxycell
    Participant

    I have setup another RetroPie with the latest from github but I can’t seem to get my controller to work with any of the libretro emulators

    I went and re-built everything again and my Logitech F710 wireless controller is still “not configured”.

    What I mean by this is the small yellow text that pops up at the start after saying “Logitech F710 connected: not configured” – it flashes very quickly

    I have done the EmulationStation controller setup obviously and the controller config is here: /opt/retropie/configs/all/retroarch-joypads/LogitechGamepadF710.cfg

    Am I missing something? It has been a while since I last tried this out but I don’t recall it being this weird.

    #111842
    Profile photo of herbfargus
    herbfargus
    Moderator

    Tap the top right shoulder button

    #111843
    Profile photo of proxycell
    proxycell
    Participant

    Hi herbfargus – when do I tap that button?

    thank you for your help as well!

    • This reply was modified 1 year, 4 months ago by Profile photo of proxycell proxycell.
    #111847
    Profile photo of herbfargus
    herbfargus
    Moderator

    When you’re in retroarch (I had a similar issue with my f310 ) but if it just doesn’t configure at all I don’t know what to tell you.

    #111848
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    what have you got the lil switch set at? X or D

    • This reply was modified 1 year, 4 months ago by Profile photo of InsecureSpike InsecureSpike.
    #111952
    Profile photo of proxycell
    proxycell
    Participant

    @herbfargus: I will try that again

    @insecurespike: X, is that the “modern” one?

    • This reply was modified 1 year, 4 months ago by Profile photo of proxycell proxycell.
    #112446
    Profile photo of nschloe
    nschloe
    Participant

    I have the exact same issue with the F310. Have you been able to resolve it yet?

    #112470
    Profile photo of aticatac
    aticatac
    Participant

    Same issue with Logitech Rumblepad 2…help!!

    #112492
    Profile photo of proxycell
    proxycell
    Participant

    @nschloe & @aticatac:
    are you two using 3.2.1 or 3.3?

    i will re-test this today

    #112508
    Profile photo of nickademusss
    nickademusss
    Participant

    I am using the latest retro pie, a build from a week ago, for some reason it won’t auto configure any controller after you set up one type, I have a buffalo controller and it was what I configured first, it see’s that one fine. But plug in the Logitech F710 and it doest do the auto recognize at all. Even with the keyboard and other controllers unplugged. The older 3.0 version did, kind of strange….

    #112529
    Profile photo of nschloe
    nschloe
    Participant

    @proxycell I’m running on the 3.3 Jessie (beta) image.

    #112542
    Profile photo of proxycell
    proxycell
    Participant

    ok, i just did everything fresh again
    fresh Wheezy on the card, then installed from source in this order ->
    1. Emulation Station
    2. RetroARch
    3. A bunch of emulators
    4. Added some roms and restarted the console
    5. entered a game and it once again throws the yellow text up onto the screen saying my controller is not configured

    i will continue testing this to find out why this is the case – these controllers have always worked with RetroPie

    #112555
    Profile photo of proxycell
    proxycell
    Participant

    ok, i got my controller configured again!
    i had to do it from inside RetroArch’s menu (loaded up a game, pressed F1)
    then i manually configured each button again and saved this configuration. it created a new file in my retroarch-joypads directory

    i have since added in all the hotkeys again

    I am uploading this file for you all to use: “http://iruberleet.org/files/Logitech F710 Gamepad (XInput).cfg” – please copy this entire link inside the quotation marks and download it

    i had this controlled set to the “X” position for xinput, i will likely create another for direct – i do not guarantee that this will work for you all but if you do in fact have the F710 this should work in xinput mode

    Direct Input (D): “http://iruberleet.org/files/Logitech F710 Gamepad (DInput).cfg” – can’t get the hotkeys to work but the regular stuff works perfect now – just leave it in XINput

    • This reply was modified 1 year, 3 months ago by Profile photo of proxycell proxycell.
    • This reply was modified 1 year, 3 months ago by Profile photo of proxycell proxycell.
    • This reply was modified 1 year, 3 months ago by Profile photo of proxycell proxycell.
    #112569
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    i’ll have a test too shortly

    #112672
    Profile photo of jpeake
    jpeake
    Participant

    Same issue here using F310. controllers work fine in EmulationStation, but get “not configured” yellow warning in any games.

    tried xboxdrv reinstall, xbox driver off, sdd–>udev, reboots etc etc.

    #112674
    Profile photo of Nima
    Nima
    Participant

    find problem and fixed it

    hi
    yes . i had controller problems (x360 – ps3 – twin joy) in new ver 3.3 and 3.3.1 . finly after half hour find a slution . its changin joypad driver from sdl2 to udev .

    its best to do after starting fresh instal and after configing joy in emulation station .

    i dont have retropi runing now but i remember some :
    start > retropie > setup-retropie [2nd from down] > setup [3rd section] > config retro arch setting > change commen setting [1st section] > all [1st] > change joypad driver from sdl2 to udev . after that back to first page and perform rebbot . and all set .

    plz after testing post result . thanks

    #112675
    Profile photo of lostmuppet
    lostmuppet
    Participant

    Having the same issue with a PS4 controller showing as not configured on 3.3.1 but my USB SEGA Saturn pad works fine.

    #112678
    Profile photo of lostmuppet
    lostmuppet
    Participant

    Just tested your fix and I can confirm all my controllers now work perfectly for me, thank you.

    #112680
    Profile photo of Nima
    Nima
    Participant

    you welcome

    #112761
    Profile photo of marc
    marc
    Participant

    I’ll start by saying I’m new to this, but I have been reading everything I can to try and figure out where I am going wrong.
    I am using Jessie with the latest retropie (must be 3.3?), and a rumble pad 2
    My problem sounds just like everyone else’s. I can use the joystick and configure it in the GUI (emulation station). However, once I launch a game, it doesn’t respond, saying ‘rumble pad 2 USB controller not configured (it seems like it’s detecting it quite well for the recognition of the controller in the message!). I’m back to the keyboard only.

    Some people have mentioned pushing f1 in-game can get to the controller setup and it works from there. But, I can’t seem to launch a menu by pushing F1.

    I have a suspicion that there is nothing at all under:
    /opt/retropie/configs/all/retroarch-joypads/
    And from all my reading it seems like something should be there. I feel like that’s why the ROM’s are telling me my joystick is not configured.

    I’ve tried changing the drivers to Udev and rebooting, but that didn’t help.
    Am I right in my suspicion about the missing file? Is there anyway to generate it?

    Thanks for any help.

    Marc

    #112781
    Profile photo of proxycell
    proxycell
    Participant

    try SDL controller driver

    #112801
    Profile photo of arnavxv
    arnavxv
    Participant

    I have the same issue. I am using a raspberry pi2, wheezy 3.3.1, and I’ve tried updating the drivers to udev and it’s not working. The right shoulder button method isn’t working either. I also updates all my binaries and scripts. Any suggestions? I am using the same controller (logitech f710 btw).

    EDIT: Furthermore, when launching the RGUI from the retropie settings, I am unable to use my controller. It seems like no retroarch configuration was made. Furthermore, in configs/all/retroarch.cfg, retroarch.cfg is empty. Any fixes?

    • This reply was modified 1 year, 3 months ago by Profile photo of arnavxv arnavxv.
    #112829
    Profile photo of marc
    marc
    Participant

    try SDL controller driver

    I have tried both SD12 and UDEV options (with reboots), and they both have the exact same results. I have found 2 places to change this setting: in retroarch gui (launched from the retropie section IN emulation station) and the retro-pie setup file (change common settings). I’ve tried changing them both together but it doesn’t do anything one way or the other. I still get the controller not configured message when starting a ROM.

    #112832
    Profile photo of Nima
    Nima
    Participant

    i dont know what is changed in last 2 update by devs. i hope floop and herbfargus make a new guide video on yt for controller in last update

    #112865
    Profile photo of proxycell
    proxycell
    Participant

    please review this commit: https://github.com/RetroPie/RetroPie-Setup/commit/683115fddffb12e2b5aad82b90f6548a984f88e4

    The joystick driver was switched from sdl2 to udev – likely do to these issues we’ve been having here

    i see another commit to deal with an autostart issue and some stuff for jessie-compatability too so things are being worked on by good and competent folken

    #112968
    Profile photo of daniel
    daniel
    Participant

    Changing the config files (including cfgs for the emulators) to Udev changed my message (upon starting an emulator) to “Logitech F310 Configured on Port 0”, but it still didn’t do anything. Unplugging and replugging the controller fixed the problem and they work now…

    Still can’t get my keyboard to work tho… :/

    #113028
    Profile photo of nschloe
    nschloe
    Participant

    @daniel Exactly the same experience here: Changing to udev reports the controller as “Configured”, but they only work when replugging after a rom is started.

    #113059
    Profile photo of SwissPi
    SwissPi
    Participant

    For my Logitech Gamepad F510 I needed 2 changes:

    /opt/retropie/configs/all/retroarch.cfg
    input_joypad_driver = sdl (was input_driver = sdl2 )

    /opt/retropie/configs/all/retroarch-joypads/LogitechGamepadF510.cfg
    input_driver = sdl ( was input_driver = “udev” )

Viewing 28 posts - 1 through 28 (of 28 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar