Configuring Control Panel and General Questions?

Home Forums RetroPie Project Everything else related to the RetroPie Project Configuring Control Panel and General Questions?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of husar husar 3 years, 5 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #3289
    Profile photo of husar
    husar
    Participant

    I am finally at a point that I can configure my control panel in my arcade build. Yea! Big thanks to all the efforts that are going into the project. I have some questions about configuration and a few general questions I am hoping to get answers for.

    I have a two joystick setup, 6 buttons each player, 1p and 2p buttons. 1p coin and 2p coin. Plus 4 extra buttons I can map for other things. I have a USB trackball with 2 mouse buttons and spinner. In addition I have two retro console control on order that shoudl arrive Wednesday. I am using an IPAC to wire everything up.

    The plan is to use the joystick and buttons for a much as possible.

    Here is what I think I understand….

    The config file I will need to be editing for MAME for my control panel is located at “/home/pi/RetroPie/configs/all/retroarch.cfg”. I am using the default MAME install which is MAME4ALL. Can someone verify the location is correct?

    I tried to run through the config setup last night via the GUI but this did not seem to have an option to do the button presses and save for MAME. I assuse I need to enter the buttons commands manually? Is there a command I can run to automate the MAME config so I can just press and assign buttons? If not, is there a default file I can see to map all my control joys and buttons? I found this in another post and I am wondering if I run this will to do the auto config GUI for MAME?

    COMMAND=retroarch -L /home/pi/RetroPie/emulatorcores/imame4all-libretro/libretro.so –config /home/pi/RetroPie/configs/all/retroarch.cfg –appendconfig /home/pi/RetroPie/configs/mame/retroarch.cfg %ROM%

    Questions about MAME, I noticed there was an option to install AdvMame. If I do this I assume now MAME4 ALL will no longer be an option? Everything I am read says MAME4ALL seems to be the more stable version?

    Last, I seem to have deleted the one file that gets installed for DOOM to work. I have the WADs but need to get the file that is install as part of the default install.

    Well, I think that is it for now. I am not having any luck getting anything working NEOGEO outside of MAME so as soon as I get the above taken care of NEOGEO is next on my list to get working.

    Thanks again.

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar