Commodore 64 Emulation

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 15 replies, has 13 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 6 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1700
    Profile photo of depmod
    depmod
    Participant

    Hi,

    I was able to map my buttons and now can play NES games well. Then I tried C64 emulation I have mainly 2 issues:

    1) I downloaded RiverRaid and IK+. I can’t seem to use the controller and the keyboard except the VICE menu. Also I can’t run it full screen. I tried double size from the menu it grows bu then upper half of the screen is not visible o TV. (BTW I connect via HDMI) I’ve found this (http://www.raspberrypi.org/phpBB3/viewtopic.php?f=41&t=4581) but I couldn’t manage to get Vice full screen. Does anybody have an idea? Thanks.

    #3726
    Profile photo of smartroad
    smartroad
    Participant

    I am having the same issue. I was hoping to get it running as a surprise for the otherhalf (loved to play Way of the Exploding Fist back in the day) over Christmas. Not going to bother at the moment as it fills a tiny section in the center of the screen.

    Running it on composite video here. No settings seem to make it work ๐Ÿ™

    #3803
    Profile photo of wfmde
    wfmde
    Participant

    I changed

    VICIIDoubleSize=1

    from 0 to 1 in /home/pi/.vice/sdl-vicerc.

    After restart I got pretty fullscreen.

    #5496
    Profile photo of izeko2004
    izeko2004
    Participant

    I cant seem to find this file on my retroPie image.

    Can you help. I am using ftp to read the sd card and not inserting it in PC.

    /home/pi/.vice/sdl-vicerc.

    #5505
    Profile photo of retrofredde
    retrofredde
    Participant

    Can you see the .vice folder? I can’t see the .vice folder when using a ssh client but I see it when using ftp. Sdl-vicerc should be inside /home/pi/.vice

    #5510
    Profile photo of wrichards
    wrichards
    Participant

    i cant seem to find this, im using WinSCP.. cant see it under startx either…

    i did NOT install VICE, im using retropie stock. I read a thread, seems this works under startx environment. I cant seem to find a 2x video as is.. so i think im looking for somthing thats not there unless you install VICE outside of the stock retropie install.. am i right?

    SOLVED IT: Sorry to be an idiot ๐Ÿ˜‰

    #5592
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    hi, how did you solve this?
    via Cyberduck, i can’t see a .vice folder in /home/pi/ i see other /. folders but not that one?
    i’m running the 1.91 .img setup
    thanks

    *edit*
    i had to create the .vice folder, and googled for the sdl-vicerc file, then edited to my liking

    #6762
    Profile photo of IIeBoy
    IIeBoy
    Participant

    1) I found the following settings that completely fix the screen size.

    Type:
    $ nano /home/pi/.vice/sdl-vicerc

    Change the following line settings:

    VICIIDoubleSize=1
    VICIIScale2x=0
    WarpMode=0

    Dev, I recommend integrating these settings changes into the config file! (Thanks to ‘Jeff’: http://ledgerlabs.us/raspberrypi/retropie-fix-x64-vice-settings-for-fullscreen)

    2) I can only rarely get music to work. Then suddenly I’m back to no sounds, reboot after reboot. I’m sure I changed no settings since. When it worked it was beautiful… but never again. Any surefire ways to get sound to be reliable?

    Other than all the above, it’s great ๐Ÿ˜›

    Thanks!

    IIeBoy

    #15901

    Mepteptellusa

    Wiecie, liczy sie

    BBCode you used is not allowed.

    , programy, informacje i hosting …

    #84966
    Profile photo of flolob
    flolob
    Participant

    I put my raspberry pi in an old Commodore C64 case using the keyrah 2 interface.
    Everything works fine, but I can’t fix the the screen size.
    Changing the video settings to “double size in the emulator leads to a crash.

    The settings in “sdl-vicerc” mentioned above

    VICIIDoubleSize=1
    VICIIScale2x=0
    WarpMode=0

    can’t be changed because they don’t exist anymore. (New Version of Vice/Retropie ?)

    I am using the svideo output, the overscan is properly configured to match the screen size.
    Where is the lucky guy (or girl) who got C64 emulation working in fullscreen ?
    Please get in touch with me !

    #84984
    Profile photo of flolob
    flolob
    Participant

    Problem solved !

    I installed the runcommand-script: sudo ./retropie_packages.sh runcommand

    When starting “vice” press “x” or “m”, then you can select the desired video mode, for me this is PAL 4:3.
    The game started in fullscreen and the ingame video-settings work properly.
    And the emulator even won’t crash on exiting. Dispmanx-sdl is turned on for vice.

    sudo ./retropie_packages.sh dispmanx

    The emulation speed was a little bit slow, so I overclocked the raspberry pi to “moderate”. Now the speed is fine.

    Thank you so much for this great piece of software called Retropie !!

    #107630
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Hello,

    Just trying this, but I get an error:

    pi@retropie ~ $ sudo ./retropie_packages.sh runcommand
    sudo: ./retropie_packages.sh: command not found
    pi@retropie ~ $

    #107635
    Profile photo of herbfargus
    herbfargus
    Moderator

    try cd RetroPie-Setup first…

    #107639
    Profile photo of buzz
    buzz
    Keymaster

    you are also not in the right folder.

    #107660
    Profile photo of g0nz0uk
    g0nz0uk
    Participant

    Thanks herbfargus, you always give an example to help a novice like me.

    Now I get further, I have the blue C64 start screen in full screen but the games have a huge black border. I have tried changing the ingame settings without success for my 19 inch monitor. I go to Video settings > size settings and I have tried everything in

    #107701
    Profile photo of herbfargus
    herbfargus
    Moderator

    The solution is listed above as well as in the wiki:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Commodore-64

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar