CMA – Dynamic Memory Split

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of dk999 dk999 2 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5384
    Profile photo of OlDrunk
    OlDrunk
    Participant

    Any one here tried setting up CMA on there RetroPie and how well did it work? I have the old 256M RPi and was considering trying CMA – Dynamic Memory Split so my pi can still be used for other things when not playing games.

    #85099
    Profile photo of dk999
    dk999
    Participant

    Hi Guys!
    Tried to use CMA on my Pi with Firmware 3.12.35+, though I only get a “lwl0: error creating SDL Window” and be greeted by the terminal instead of Emulationstation.

    I’ve got the 512 B+ Model and the following cmdline.txt

    dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait coherent_pool=6M smsc95xx.turbo_mode=N
    

    and config.txt

    
    disable_overscan=0
    overscan_scale=1
    
    overscan_left=16
    overscan_right=16
    overscan_top=16
    overscan_bottom=16
    
    hdmi_group=1
    hdmi_mode=16
    
    arm_freq=1000
    core_freq=500
    sdram_freq=500
    over_voltage=6
    over_voltage_sdram=4
    avoid_safe_mode=1
    gpu_mem=256
    gpu_mem_256=160
    gpu_mem_512=416
    cma_lwm=16
    cma_hwm=32
    force_turbo=0
    overscan=1
    

    It doesn’t work, no matter what I’m doing with the gpu_mem_512 line. It’s like emulationstation doesn’t like the cma-commands at all.
    By the way, when using i.e. 384MB for the gpu as a fixed value ( no CMA ), I only get a blank white screen for emulationstation.

    Any suggestions?

    • This reply was modified 2 years, 3 months ago by Profile photo of dk999 dk999.
Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar