Changing resolution for emulators

Home Forums RetroPie Project Everything else related to the RetroPie Project Changing resolution for emulators

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.


This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 2 years, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #48853
    Profile photo of docsnivy


    I’ve been noticing that all emulators are running at an unnecessary 720p(I primarily play on a 1080p hdtv). Because of this, select games, i.e. UMK3, Kirby Super Star, Star Fox, et cetera, et cetera, put the Pi under heavy stress and cause the entire game to lag, the first sign usually being that choppy, grainy audio that you will get.

    I’ve tried changing to VGA mode, lowering resolution output, editing to output in VGA mode if in HDMI mode, even overclocking(not too high though, even with aluminum heat sinks; I would like for my Pi to last). All of which come to no fix for my issue.

    Is there a way to hard set each emulator to run in 480i, at the max 480p?

    Profile photo of alanb

    each emulator has its own setting in /home/pi/.emulationstation/es_systems.cfg file, try edditing this and replace ( 4) with ( 1) on each of the emulator settings, this should force 640×480 at 60Hz.

    Profile photo of rick

    Hi, did it work? I think every emulator should come with that resolution. They dont need more than that.

    I lost too much time trying to make work RCA On FHD TVs without results xd. For the same reason that docsnivy trying to avoid the stress on the py. And keep compatibility with the grandma tv xd

    Profile photo of docsnivy

    It worked for the most part, but very intesive games, i.e. Kirby Super Star, Star Fox, still show heavy lag.

    Profile photo of trimmtrabb

    The Pi can struggle with SNES emulation, particularly Super FX games, the emulator ports are based on older SNES emulators for performance reasons but the trade off is compatibility

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar