Change resolution of console and emulators

Home Forums RetroPie Project Video Output on RetroPie Change resolution of console and emulators

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 2 voices, and was last updated by Profile photo of buzz buzz 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #106087
    Profile photo of rasmushauschild
    rasmushauschild
    Participant

    Hi Retropie forum.
    I recently bought a small SPI OLED from Adafruit, and i finally got it working with the fbcp driver! It displays Emulationstation perfect in fullscreen, but as soon as I go to the console or launch an emulator the x resolution crops to what seems half of normal(128×128)making the image very slim.
    Why does it do this? How can I make it stop?
    Any answer is very appreciated!

    #106104
    Profile photo of buzz
    buzz
    Keymaster

    if you exit out of emulationstation without launching any games, does it still do this ?

    #106108
    Profile photo of rasmushauschild
    rasmushauschild
    Participant

    Yes, it does that every where except emulationstation.

    #106109
    Profile photo of buzz
    buzz
    Keymaster

    if you disable emulationstation on bootup (via retropie-setup / supplementary menu), and boot into console, does the resolution look correct ?

    If not, you might want to try changing some config.txt related settings. Although I know little about this screen / hardware though and need to read up on it.

    • This reply was modified 1 year, 7 months ago by Profile photo of buzz buzz.
    #106111
    Profile photo of buzz
    buzz
    Keymaster

    Please can you link me to the display you bought ?

    #106112
    Profile photo of rasmushauschild
    rasmushauschild
    Participant

    Here’s the link to the screen https://www.adafruit.com/products/1431
    I’m not home right now, but I’ll try to disable emulation station as you wrote when I get home 🙂

    #106418
    Profile photo of rasmushauschild
    rasmushauschild
    Participant

    Hi, sorry for not answering!
    So I got it to work perfectly by editing some config files, as you wrote!
    Thank you so much for your help!

    #106419
    Profile photo of buzz
    buzz
    Keymaster

    Please share your fix so it can be of help to anyone else who may come across this thread. thanks.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar