Can't open RGUI; Hotkeys are working only sometimes

Home Forums RetroPie Project Everything else related to the RetroPie Project Can't open RGUI; Hotkeys are working only sometimes

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 9 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #90525
    Profile photo of Volans
    Volans
    Participant

    Hi everybody πŸ™‚

    I used the latest SD card image (01/22/2015) to setup RetroPie on my Raspberry Pi 2. After I changed the /boot/config.txt for fixing the sound and fullscreen on my HDTV, I wanted to use shader for SNES games. So I checked/uncommented:

    video_shader_enable = true
    video_shader_dir = /opt/retropie/emulators/retroarch/shader/
    input_shader_next = m
    input_shader_prev = n

    But “m” and “n” don’t do anyting when the emulator runs. :/
    So I wanted to open RGUI and switch the shaders there.

    input_menu_toggle = F1

    But “F1” doesn’t work either. Then I wanted to exit the emulator with escape and that was working.. for the first time. When I tried another game, later even exiting via escape didn’t work. I’m using wireless XBOX360 controllers and mapped button 6 (select) for exit the emulator:

    input_exit_emulator_btn = “6”

    ..the same problem here. Sometimes it works, sometimes not.

    I read every thread related to those problems but I couldn’t find a solution. πŸ™

    The keyboard works. If I switch to console, I see the Ms and Ns I typed for swithing the shaders. πŸ˜‰ “input_enable_hotkey” is only in one line with “nul“.

    I would appreciate every help. πŸ™‚

    PS.:

    If I would install RetroPie on Raspian via installscript from source, would this fix the black screen issue in Super Mario Kart 64 Multiplayer?^^

    http://blog.petrockblock.com/forums/topic/n64-two-player/

    • This topic was modified 2 years, 1 month ago by Profile photo of Volans Volans.

    #90543
    Profile photo of Volans
    Volans
    Participant

    I’m only able to open RGUI if I run the retroarch binary with “–menu”. :/

    #90549
    Profile photo of Floob
    Floob
    Moderator

    This should help explain the hotkey behaviour:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #91620
    Profile photo of Volans
    Volans
    Participant

    Thank you, but I already saw this video. It’s very good.. but he explains how they should behave.

    After some hours trying to solve the problem by editing the configs, I decided to begin from scratch. This time with a Raspian image and RetroPie compiled from sources. After that I configured my XBOX360 controller:

    input_player1_joypad_index = "0"
    input_player1_b_btn = "0"
    input_player1_y_btn = "2"
    input_player1_select_btn = "6"
    input_player1_start_btn = "7"
    input_player1_up_btn = "13"
    input_player1_down_btn = "14"
    input_player1_left_btn = "11"
    input_player1_right_btn = "12"
    input_player1_a_btn = "1"
    input_player1_x_btn = "3"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_l2_axis = "+2"
    input_player1_r2_axis = "+5"
    input_player1_l3_btn = "9"
    input_player1_r3_btn = "10"
    input_player1_l_x_plus_axis = "+0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_y_plus_axis = "+1"
    input_player1_l_y_minus_axis = "-1"
    input_player1_r_x_plus_axis = "+3"
    input_player1_r_x_minus_axis = "-3"
    input_player1_r_y_plus_axis = "+4"
    input_player1_r_y_minus_axis = "-4"

    ..and added input_exit_emulator_btn = “6”, because I want to be able to stop the emulator via controller. Then, without changing any hotkey behaviour, the follwing works (not):

    SNES:
    Exiting via ESC doesn’t work
    RGUI via F1 doesn’t work
    Switching shaders via M&N doesn’t work
    Exiting via SELECT (btn#6) works

    Playstation:
    Exiting via ESC doesn’t work
    RGUI via F1 doesn’t work
    Switching shaders via M&N doesn’t work
    Exiting via SELECT (btn#6) works

    N64:
    Exiting via ESC works
    RGUI via F1 doesn’t work
    Switching shaders via M&N doesn’t work
    Exiting via SELECT (btn#6) doesn’t work

    Then I changed the hotkey behaviour to “Press ALT to enabled hotkeys“:

    SNES:
    Exiting via ALT+ESC works
    RGUI via ALT+F1 works
    Switching shaders via ALT+M&N works
    Exiting via SELECT (btn#6) works

    Playstation:
    Exiting via ALT+ESC works
    RGUI via ALT+F1 works
    Switching shaders via ALT+M&N works
    Exiting via SELECT (btn#6) works

    N64:
    Exiting via ALT+ESC works
    RGUI via ALT+F1 doesn’t work
    Switching shaders via ALT+M&N doesn’t work
    Exiting via SELECT (btn#6) doesn’t

    I’m really confused. :/ I didn’t change any other configs..

    ..just for fun I tested input_exit_emulator_btn = “9” to have the analog stick for exiting the emulators: It doesn’t work in SNES, N64 and Playstation. πŸ™

    PS: After compiling I had to run this command, because some directories were owned by root. Is this normal?

    sudo chown -hR pi:pi /home/pi/

    I hope somebody can help me..

    • This reply was modified 2 years, 1 month ago by Profile photo of Volans Volans.
    #91649
    Profile photo of Floob
    Floob
    Moderator

    You dont mention if you have included this line?

    input_enable_hotkey_btn = “”

    Remember hotkeys will only work if the enable is pressed, so you have to hold select and then press M for example to scroll through the shaders. Same for RGUI with F1, you must hold your enable hotkey button.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #91765
    Profile photo of Volans
    Volans
    Participant

    Test: I posted something, then I wanted to add/edit something and now the post is gone. O.o

    #91767
    Profile photo of Volans
    Volans
    Participant

    Yes, I know πŸ˜‰ This line was by default at the end of ‘/opt/retropie/configs/all/retroarch.cfg’. > “input_enable_hotkey_btn = nul
    After I changed the hotkey behaviour: ‘/home/pi/RetroPie-Setup/retropie_setup.sh’ > “Configuration” > “Change hotkey behaviour” > “Press ALT to enable hotkeys.”, this line changed into “input_enable_hotkey_btn = alt” and “input_menu_toggle = F1” was added.

    In my last post I listed the behaviour in every emulator I want to use twice. One time with “Hotkeys enabled (default)” and the other time with “Press ALT to enable hotkeys”. The best result I had with the second option: I was able to open RGUI with ALT+F1, switch shaders with ALT+M/N and exit the emulator with ALT+ESC. But only in SNES and Playstation emulator. In N64 emulator only ALT+ESC for exiting works.. nothing more. Even the button (btn#6; SELECT) doesn’t work. And if I try to use left analog stick (btn#9) for exiting the emulator it doesn’t work at all.. SNES, N64, PS. :/

    #91782
    Profile photo of Volans
    Volans
    Participant

    I made a backup of my retroarch.cfg and deleted all out commented lines:

    core_options_path = /opt/retropie/configs/all/retroarch-core-options.cfg
    The post deleting line of death” πŸ˜€
    system_directory = /home/pi/RetroPie/BIOS
    config_save_on_exit = false
    video_fullscreen = true
    video_threaded = true
    video_smooth = false
    video_aspect_ratio = 1.77
    video_aspect_ratio_auto = false
    video_shader_enable = true

    video_shader_dir = /opt/retropie/emulators/retroarch/shader/
    overlay_directory = /opt/retropie/emulators/retroarch/overlays
    input_autodetect_enable = true
    joypad_autoconfig_dir = /opt/retropie/emulators/retroarch/configs/

    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down

    input_exit_emulator = escape
    input_shader_next = m
    input_shader_prev = n
    input_rewind = r
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    video_gpu_screenshot = true

    input_enable_hotkey = alt
    input_exit_emulator_btn = “6”
    input_menu_toggle = F1

    input_player1_joypad_index = “0”
    input_player1_b_btn = “0”
    input_player1_y_btn = “2”
    input_player1_select_btn = “6”
    input_player1_start_btn = “7”
    input_player1_up_btn = “13”
    input_player1_down_btn = “14”
    input_player1_left_btn = “11”
    input_player1_right_btn = “12”
    input_player1_a_btn = “1”
    input_player1_x_btn = “3”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_axis = “+2”
    input_player1_r2_axis = “+5”
    input_player1_l3_btn = “9”
    input_player1_r3_btn = “10”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+3”
    input_player1_r_x_minus_axis = “-3”
    input_player1_r_y_plus_axis = “+4”
    input_player1_r_y_minus_axis = “-4”

    All lines added or changed by me are bolt.

    #91785
    Profile photo of Volans
    Volans
    Participant

    Off topic: I don’t see a way to delete already posted things. Here it is:

    Edit your post and add this line without spaces πŸ˜‰ –>

    a s s e t s _ d i r e c t o r y = / o p t / r e t r o p i e / e m u l a t o r s / r e t r o a r c h / a s s e t s

    A good way to raise the post count for an account without flooding. Sometimes I think bugs are magically attracted by me πŸ˜€

    • This reply was modified 2 years, 1 month ago by Profile photo of Volans Volans.
    #91808
    Profile photo of Floob
    Floob
    Moderator

    Part of the issue is you have auto select controller set to true, but then you specify your controller setup in the main retroarch.cfg. I’d do one or the other.

    input_autodetect_enable = true

    or just set this false:
    input_autodetect_enable = false

    If I was you I would set a button (joypad) to enable hotkeys rather than trying to get them to work on their own. The video above runs through a full example.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    • This reply was modified 2 years, 1 month ago by Profile photo of Floob Floob.
Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar