Can't Exit Emulator with controller

Home Forums RetroPie Project Controller Configuration in RetroPie Can't Exit Emulator with controller

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of vinretropiemame vinretropiemame 1 year, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #109173
    Profile photo of vinretropiemame
    vinretropiemame
    Participant

    Hi,
    I know this has been discussed before but I and having problems exiting from the emulators using the controller. I have followed a setup video on youtube and all worked well. I am using a joystick and buttons with a usb interface. Configuring the controller I setup 3 buttons and 2 additional buttons for start and select. I done jstest and buttons 0,1,2 come on when pressed (game buttons), pressing the start button No. 8 comes on and select is No.9. All seems OK.

    I went the the retroarch config file and added the 2 lines for a hotkey.

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9

    When in the game pressing the 2 buttons together does nothing, but I can still exit using the esc key on the keyboard.

    Can anyone give me a list of checks and “how to’s” to find the problem?

    Thanks guys 🙂

    #109187
    Profile photo of vinretropiemame
    vinretropiemame
    Participant

    I have noiced at the end of the retroarch.cfg file is the following line:

    input_enable_hotkey = null

    is this stopping my command.

    Also else where in the file I have:

    input_enable_hotkey =

    Could this have an effect.

    In the Installation file – setup – 310 do i need to enable hotkeys?

    Again thanks for any help

    #109198
    Profile photo of jwingo
    jwingo
    Participant

    I lost my hotkeys for some reason as well and went into the RetroArch settings on the main menu of the RetroPie. I think it was called RGUI. In the controls if you dig around you can see your hotkey settings and can press the button to reset them to whatever you want. I tried fixing the file as well and couldn’t get it to work but this was way easier once I looked around.
    Hopefully that helps.

    #109200
    Profile photo of vinretropiemame
    vinretropiemame
    Participant

    Worked Thank. now to build a cab for the pimame. cheers

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar