Can't change keyboard locale

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of p-rock p-rock 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #96994
    Profile photo of p-rock
    p-rock
    Participant

    I’m running retropie v3 beta 2 on a raspberry pi 2 that I recently purchased. When I tried to do some command line work last night, I noticed some of the characters I typed didn’t appear on screen as they should (I would get a british pound sound in place of an #, for example). After a little sleuthing, I realized my keyboard was keyboard was set up as a British, and not American keyboard. On a freshly installed retropie image, I did a “sudo raspi-config” in the terminal and then set the localization to US-UTF-8, the time zone to East Coast, and the keyboard to a standard 104 key American keyboard (I’m running a wireless Logitech K400 keyboard FYI). After performing a reboot, my keyboard is still not registering the keys I would expect–still getting pound signs and other unexpected characters. I did a “locale” command from the terminal, and everything is set to US-UTF-8. When I go back into raspi-config, it seems as though the US-configuration has “stuck” as well.

    Does anybody have any idea what I could be doing wrong? Is there some other way I should try to configure my keyboard? I spent maybe 2 hours banging my head against the wall last night trying to get my americanize my keyboard to no avail.

    #96995
    Profile photo of mavic19
    mavic19
    Participant

    Mine does the same. I had to play around to find what key the # symbol was assigned to (I think it was the \ key….I know it was a key in that vicinity). The @ key assignment was another that was off and, if I remember correctly, was found to be the ? key on the keyboard (they had swapped locations for that one. So whatever emblem pops up when you try to type @ (SHIFT+2), try the key for the emblem that displays in jstest. I’m pretty sure it was the ? key though.

    Once I got that figured out, I just worked around it.

    • This reply was modified 1 year, 12 months ago by Profile photo of mavic19 mavic19.
    #96997
    Profile photo of p-rock
    p-rock
    Participant

    I have been able to mostly work around the issue so far, but there are a few keys characters needed for command line work (like “|,” for instance), that I haven’t been able to find using the current keyboard layout.

    Mavic19, are you saying you tried the same procedure as me to change the keyboard locale, and it didn’t work for you either? Is there some bug in the current build of retropie that’s somehow preventing me from getting the proper keyboard layout?

    #96999
    Profile photo of mavic19
    mavic19
    Participant

    Honestly, I didn’t try to get the keyboard reconfigured. I tried a couple different brands of keyboards I had around the house to see if there was any change, but it didn’t help. Since I set mine up in a full arcade configuration (no need for a keyboard), I just worked around the issue. Since then, I’ve set up WinSCP/Putty to access terminal from my home computer and haven’t had to deal with the issue. For some reason, through WinSCP the keyboard layout is exactly as it should be. I’ve found that, with the Raspberry Pi and Retropie, there is a lot of tinkering to get it where you want it and, more frustrating, (and, to coin a phrase) there seems to be a million ways to skin a cat with it.

    #97021
    Profile photo of theguyonthecouch
    theguyonthecouch
    Participant

    I had the same problem. I changed the keyboard layout to US using the config script and it still didn’t work. The trick is to run apt-get update and upgrade afterwards (when online, of course)…reboot…then your key map will be as configured (at least, that is what works for me every time).

    #97029
    Profile photo of p-rock
    p-rock
    Participant

    For what’s it’s worth I managed to get it to work, although I’m not 100% sure which particular step did the trick for me. I performed the steps recommended by theguyonthecouch, but that didn’t seem to do the trick. What finally seemed to fix it was selecting a generic logitech keyboard in the keyboard layout settings in the raspi-config script, and forcing it to be a generic US keyboard. After a reboot it worked like a charm. I’m wondering if using the generic 104 key keyboard I was originally trying to use was the cause of the problem.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar