Can´t access to Retroarch settings!

Home Forums RetroPie Project Everything else related to the RetroPie Project Can´t access to Retroarch settings!

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 22 replies, has 8 voices, and was last updated by Profile photo of h0rbie h0rbie 1 year, 10 months ago.

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #99373
    Profile photo of pausuri
    pausuri
    Participant

    Hi, I just made a fresh install of the RetroPie 3 Beta 2, I update the emulator via the retropie script, everything works properly except when I try to access to the libretto settings of any emulator (pressing select + X) it freezes the raspberry Pi and I have to unplug and plug back in order to reboot it

    http://s8.postimg.org/juuuhyfqt/IMG_1222.jpg

    Any way to fix it?

    Many thanks!

    • This topic was modified 1 year, 10 months ago by Profile photo of pausuri pausuri.
    • This topic was modified 1 year, 10 months ago by Profile photo of pausuri pausuri.
    • This topic was modified 1 year, 10 months ago by Profile photo of pausuri pausuri.

    #99378
    Profile photo of Floob
    Floob
    Moderator

    It should move off that screen if you press X, or a button on your controller. Have you tried pressing a few buttons there?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #99379
    Profile photo of pausuri
    pausuri
    Participant

    It should move off that screen if you press X, or a button on your controller. Have you tried pressing a few buttons there?

    Thanks for the quick reply, I was using Retropie 2.6 and I updated the emu via the Retropie script and same problem.

    So I decided to fresh install with the beta 2, and I updated the emus via the RetroPie script again… and same problem.

    I try to change the controller to I see if that fix something (I was using a usb snes pad) but same problem with a ps3 controller..

    #99647
    Profile photo of footwo
    footwo
    Participant

    I am getting this too, on beta 3 for Pi2. Retroarch configured the controller just fine and it works, but if I use the hot key to bring up the menu it freezes. You can connect via SSH however and restart emulationstation.

    Is yours crashing in a snes emulator by chance?

    Has anyone else seen this or found a fix?

    #99649
    Profile photo of pausuri
    pausuri
    Participant

    I am getting this too, on beta 3 for Pi2. Retroarch configured the controller just fine and it works, but if I use the hot key to bring up the menu it freezes. You can connect via SSH however and restart emulationstation.

    Is yours crashing in a snes emulator by chance?

    Has anyone else seen this or found a fix?

    Hi, the only temp fix I found is disconnecting every controller and access to the settings by keyboard, it works in that way.

    #99651
    Profile photo of footwo
    footwo
    Participant

    Thanks for the tip, unfortunately it’s worse than that. The keyboard doesn’t seem to work in game. I’ve made sure the main Retroarch config at

    /opt/retropie/configs/all/retroarch.cfg

    Has

    input_menu_toggle = f1

    But the menu doesn’t appear when I press the button. The keyboard doesn’t work for function keys or the ESC key, but does work on the cursor arrow keys and action buttons like A!

    I’m very confused

    #99664
    Profile photo of derailius
    derailius
    Participant

    make sure you’ve assigned a hotkey

    input_enable_hotkey_btn = “8” <–for example, my SNES USB select button is the hotkey… then i hold select on the gamepad and press F1 on the keyboard. and that’s how i access retroarch settings.

    #99668
    Profile photo of footwo
    footwo
    Participant

    I have a hotkey button (SELECT) enabled for the controller for things like reset, exit emulator, save/load state. It works fine, but you never used to need to push the hotkey button just to use the keyboard keys. ESC would quit the emulator and F1 would open retroarch settings when you were in the emulator itself.

    #99758
    Profile photo of h0rbie
    h0rbie
    Participant

    Hey,
    I’ve got exactly the same issue (got my own Thread in Controller Configuration for that topic, but no answers until now). I was able to configure both controllers (XBox 360 Wireless controller with the XBox 360 Driver installed) fine in ES, but the only thing I can do in the emulators is to bring on the Screen with “Welcome to retroarch…” and then I have to kill the process to quit, because it’s seems like it’s frozen. I can use Select + Start to quit, before opening the menu anyway. Tried every .cfg file, with or without XBox 360 drivers. Same result.

    #99761
    Profile photo of herbfargus
    herbfargus
    Moderator

    I can also verify this and it has been posted as an issue on github

    https://github.com/retropie/RetroPie-Setup/issues/863

    @footwo

    Regarding the “never needing to push a hotkey on the keyboard before where escape and f1 just worked” this has been issue since around January and to be honest I think its an issue with the retroarch code and the “nul” key binding this is the post I had on it a while back and never really sorted it out (I just changed the hotkey to alt from the setup script)

    http://blog.petrockblock.com/forums/topic/esc-key-not-working-to-exit-game-back-to-emulationstation/

    #99784
    Profile photo of h0rbie
    h0rbie
    Participant

    Ok,
    so I just found out, that completely disconnecting the wireless receiver makes it at least possible to use the menu with the keyboard. I will go on and try some different combinations of installing drivers and using it without drivers, with no controllers connected etc.

    #99798
    Profile photo of footwo
    footwo
    Participant

    Ok,
    so I just found out, that completely disconnecting the wireless receiver makes it at least possible to use the menu with the keyboard. I will go on and try some different combinations of installing drivers and using it without drivers, with no controllers connected etc.

    yeah, the combo of SELECT + f1 on my keyboard allows me to access the retro arch menu in-emu. a decent workaround as it lets me edit the cfg much easier now 😀

    Regarding the “never needing to push a hotkey on the keyboard before where escape and f1 just worked” this has been issue since around January and to be honest I think its an issue with the retroarch code and the “nul” key binding this is the post I had on it a while back and never really sorted it out (I just changed the hotkey to alt from the setup script)

    http://blog.petrockblock.com/forums/topic/esc-key-not-working-to-exit-game-back-to-emulationstation/

    hmm, I think I may have remapped something in the main retroarch.cfg then because I swear the ESC key and function keys work in the image of beta 2 that I burned to my SD card. but like i said above select + f1 seems to work and lets me navigate the retroarch gui menu just fine 😀

    thanks for the advice y’all

    #99846
    Profile photo of h0rbie
    h0rbie
    Participant

    I just deleted the “nul assignment” in the main retroarch.cfg in the last line for the hotkey and now I can navigate through Retroarch Menu and even exit with my controller, but retroarch still does not remember my configurations.

    E: Now I found out this:

    Select + Y Button on Controller = Freeze/No Inputs accepted
    Y (Search) Button in menu = Freeze/No Inputs accepted

    So entering the Menu with Select + f1 also does the trick for me. Workaround, but not a real fix :).

    Now everything ,except my analog sticks, is working (while analog to digital works fine).

    • This reply was modified 1 year, 10 months ago by Profile photo of h0rbie h0rbie.
    • This reply was modified 1 year, 10 months ago by Profile photo of h0rbie h0rbie.
    • This reply was modified 1 year, 10 months ago by Profile photo of h0rbie h0rbie.
    #99852
    Profile photo of windale
    windale
    Participant

    Yes it’s beta but it worked perfectly fine in beta 2 before they changed the method of setting controls. It’s the old cliché, “if it ain’t broke, don’t fix it”.

    #99869
    Profile photo of herbfargus
    herbfargus
    Moderator

    That’s why its important to have backups so that when new beta versions come out and you don’t like them you can go back to the aint broken, less updated builds you’re comfortable with. And hey perhaps if you’d care to donate a sizeable amount to the developers maybe they could spend more of their volunteer time outside of their regular lives making it more user friendly for people who want their hand held with a simple plug and play method.

    #99889
    Profile photo of windale
    windale
    Participant

    And hey perhaps if you’d care to donate a sizeable amount to the developers maybe they could spend more of their volunteer time outside of their regular lives making it more user friendly for people who want their hand held with a simple plug and play method.

    Hey, you started this project, not me. And regarding the “people who want their hand held”, I thought that was the whole point of this project, otherwise you could just manually install the emulators from the PiStore. I didn’t realize I would have to pay. Sorry for the posts. You won’t here from me again.

    #99895
    Profile photo of buzz
    buzz
    Keymaster

    Actually he didn’t (and me neither) – he just decided to put some of his free time into helping others out on the project – including much needed work on the wiki etc – video tutorials and so on.

    #99897
    Profile photo of footwo
    footwo
    Participant

    I just deleted the “nul assignment” in the main retroarch.cfg in the last line for the hotkey and now I can navigate through Retroarch Menu and even exit with my controller, but retroarch still does not remember my configurations.

    Now everything ,except my analog sticks, is working (while analog to digital works fine).

    for the saving thing, make sure the following is present in your main retroarch.cfg (I was having the same problem):

    config_save_on_exit = true

    and that will make sure that retroarch saves your config when you exit the emulator.

    wrt your analog sticks, not sure what the deal is there. I installed the ps3 driver and plugged in a ps3 controller via cable and it seems to work (tested in n64 emulator and the right stick did something with the C buttons) but I haven’t spent that much time with it as the main purpose of what im making is to emu the 8-bit/16-bit games.

    • This reply was modified 1 year, 10 months ago by Profile photo of footwo footwo.
    #99954
    Profile photo of pausuri
    pausuri
    Participant

    I just deleted the “nul assignment” in the main retroarch.cfg in the last line for the hotkey and now I can navigate through Retroarch Menu and even exit with my controller, but retroarch still does not remember my configurations.

    E: Now I found out this:

    Select + Y Button on Controller = Freeze/No Inputs accepted
    Y (Search) Button in menu = Freeze/No Inputs accepted

    So entering the Menu with Select + f1 also does the trick for me. Workaround, but not a real fix :).

    Now everything ,except my analog sticks, is working (while analog to digital works fine).

    Same happen to me, lets see if someone find a fix for this

    #99955
    Profile photo of buzz
    buzz
    Keymaster

    re-install retroarch from binary from menu 5 in retropie-setup. we have reverted to an older version.

    #99956
    Profile photo of buzz
    buzz
    Keymaster

    (Note the search dialog will still crash – be careful – we need to re-disable that again)

    #99960
    Profile photo of h0rbie
    h0rbie
    Participant

    for the saving thing, make sure the following is present in your main retroarch.cfg (I was having the same problem):

    config_save_on_exit = true

    and that will make sure that retroarch saves your config when you exit the emulator.

    wrt your analog sticks, not sure what the deal is there. I installed the ps3 driver and plugged in a ps3 controller via cable and it seems to work (tested in n64 emulator and the right stick did something with the C buttons) but I haven’t spent that much time with it as the main purpose of what im making is to emu the 8-bit/16-bit games.

    Thx for the saving thing. Seems to work for me :). My Controllers are XBox 360 Wireless, unfortunately I don’t have access to PS3 Controllers for more testing.

    re-install retroarch from binary from menu 5 in retropie-setup. we have reverted to an older version.

    Thx, will try that tomorrow. 🙂

    • This reply was modified 1 year, 10 months ago by Profile photo of h0rbie h0rbie.
    #99994
    Profile photo of h0rbie
    h0rbie
    Participant

    re-install retroarch from binary from menu 5 in retropie-setup. we have reverted to an older version.

    That actually worked for me. Found out that my analog sticks work for N64, but not PSX, so maybe emulator related.

Viewing 23 posts - 1 through 23 (of 23 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar