Cannot load/save games (*.srm)

Home Forums RetroPie Project New to RetroPie? Start Here! Cannot load/save games (*.srm)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of alienhead alienhead 1 year, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #100830
    Profile photo of alienhead
    alienhead
    Participant

    Hi!
    I downloaded the sd-card image of retropie and copied over some snes games (for example Super Mario World and Donkey Kong Country).
    But there seems to be problem with loading the saved games.
    After I exit the emulator there is a *.srm file being created (2048kB). So this seems not to be a problem of userrights.
    After I start the game, I see an empty saved game slot (i.e. in Super Mario World: “MARIO A … 0”).
    I also tried setting the auosave_interval and changing the savefile_directory but this makes no difference 🙁
    What else can I try to use the srm Files properly?

    I have an RasPi 1
    Linux retropie 3.18.11+ #781 PREEMPT Tue Apr 21 18:02:18 BST 2015 armv6l

    #100831
    Profile photo of Floob
    Floob
    Moderator

    Do bear in mind the difference between save slots/states and srm files.
    Check out these videos.

    It should auto load the srm without issue – you should be able to tell in SMW by the save game slot (of the three that are shown) – just make sure you complete the first stage or so, so it has something to save.


    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100850
    Profile photo of alienhead
    alienhead
    Participant

    @floob: Thank you for the fast reply.
    The save states work without issues (tested with autosave on exit, autoload on start of the rom).
    But the srm files are either not saved correctly or not being loaded correctly. I finished various stages and tested with SMW and Donkey Kong Country. Tomorrow I’ll try and diff the srm files before and after finishing a stage to check if something has been written.
    Is there a log file I can check for potential errors ?

    EDIT:
    *cough* finishing stages does not mean that SMW saves…
    You have to beat a castle,switch palace, or beat a ghost house…

    • This reply was modified 1 year, 10 months ago by Profile photo of alienhead alienhead.
    • This reply was modified 1 year, 9 months ago by Profile photo of alienhead alienhead.
    • This reply was modified 1 year, 9 months ago by Profile photo of alienhead alienhead.
Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar