Cannot connect with WinSCP with root

Home Forums RetroPie Project Everything else related to the RetroPie Project Cannot connect with WinSCP with root

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of rastendo rastendo 1 year, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #104745
    Profile photo of rastendo
    rastendo
    Participant

    I enabled root and was using it to log into my Pi via WinSCP without issues. I ran the command to updated the RetroPie Setup script and Binaries

    $ sudo RetroPie-Setup/retropie_setup.sh

    And after that I could no longer log in with WinSCP using root. The pi user still works with WinSCP and I can still log in with root via Putty. Here is the error message I get

    WinSCP SSH error

    Any ideas how I can fix this? I need root to edit certain files.

    • This topic was modified 1 year, 8 months ago by Profile photo of rastendo rastendo.

    #104747
    Profile photo of rastendo
    rastendo
    Participant

    Update. I found that the new setup script added the following code to the .bashrc file courtesy of ckarini

    # RETROPIE PROFILE START
    # Thanks to http://blog.petrockblock.com/forums/topic/retropie-mushroom-motd/#po                                                                                                                                                             st-3965
    
    function retropie_welcome() {
        local upSeconds="$(/usr/bin/cut -d. -f1 /proc/uptime)"
        local secs=$((upSeconds%60))
        local mins=$((upSeconds/60%60))
        local hours=$((upSeconds/3600%24))
        local days=$((upSeconds/86400))
        local UPTIME=$(printf "%d days, %02dh%02dm%02ds" "$days" "$hours" "$mins" "$                                                                                                                                                             secs")
    
        # calculate rough CPU and GPU temperatures:
        local cpuTempC
        local cpuTempF
        local gpuTempC
        local gpuTempF
        if [[ -f "/sys/class/thermal/thermal_zone0/temp" ]]; then
            cpuTempC=$(($(cat /sys/class/thermal/thermal_zone0/temp)/1000)) && cpuTe                                                                                                                                                             mpF=$((cpuTempC*9/5+32))
        fi
    
        if [[ -f "/opt/vc/bin/vcgencmd" ]]; then
            if gpuTempC=$(/opt/vc/bin/vcgencmd measure_temp); then
                gpuTempC=${gpuTempC:5:2}
                gpuTempF=$((gpuTempC*9/5+32))
            else
                gpuTempC=""
            fi
        fi
    
        local df_out=()
        local line
        while read line; do
            df_out+=("$line")
        done < <(df -h /)
    
    echo "$(tput setaf 2)
       .~~.   .~~.    $(date +"%A, %e %B %Y, %r")
      '. \ ' ' / .'   $(uname -srmo)$(tput setaf 1)
       .~ .~~~..~.
      : .~.'~'.~. :   $(tput setaf 3)${df_out[0]}$(tput setaf 1)
     ~ (   ) (   ) ~  $(tput setaf 7)${df_out[1]}$(tput setaf 1)
    ( : '~'.~.'~' : ) Uptime.............: ${UPTIME}
     ~ .~       ~. ~  Memory.............: $(grep MemFree /proc/meminfo | awk {'prin                                                                                                                                                             t $2'})kB (Free) / $(grep MemTotal /proc/meminfo | awk {'print $2'})kB (Total)$(                                                                                                                                                             tput setaf 7)
      (  $(tput setaf 4) |   | $(tput setaf 7)  )  $(tput setaf 1) Running Processes                                                                                                                                                             ..: $(ps ax | wc -l | tr -d " ")$(tput setaf 7)
      '~         ~'  $(tput setaf 1) IP Address.........: $(ip route get 8.8.8.8 2>/                                                                                                                                                             dev/null | head -1 | cut -d' ' -f8) $(tput setaf 7)
        *--~-~--*    $(tput setaf 1) Temperature........: CPU: $cpuTempC°C/$cpuTempF                                                                                                                                                             °F GPU: $gpuTempC°C/$gpuTempF°F
                     $(tput setaf 7) The RetroPie Project, http://www.petrockblock.c                                                                                                                                                             om
    
    $(tput sgr0)"
    }
    
    retropie_welcome
    
    # RETROPIE PROFILE END

    I had to comment out the second to last line that says retropie_welcome to get WinSCP to work.

    • This reply was modified 1 year, 8 months ago by Profile photo of rastendo rastendo.
Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar