Building Pi Boy, Problem with Retrogame/Retropie – Inputs Not Recognized, Help!

Home Forums RetroPie Project Everything else related to the RetroPie Project Building Pi Boy, Problem with Retrogame/Retropie – Inputs Not Recognized, Help!

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 0 replies, has 0 voices, and was last updated by Profile photo of hobbes2222 John 2 years, 7 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #56858
    Profile photo of hobbes2222
    John

    I’m building a Raspberry Pi Game Boy following this build thread: https://superpiboy.wordpress.com/. In short, this involves putting the Retropie image onto an SD card, along with the Retrogame files from Adafruit (tutorial found here: https://learn.adafruit.com/retro-gaming … pi/buttons) and then wiring the GPIO pins to the Game Boy inputs (using this board that’s custom-made for the Game Boy: http://store.kitsch-bent.com/product/co … button-pcb).

    I completed all the wiring and then moved on to configuring retrogame. As per the tutorial above, this involves editing the retrogame.c file to reflect the GPIO pins and controls you’re using, then making the retrogame file. I used the default configuration that came in the retrogame.c file (i.e. Left is GPIO pin 25, Right 9, Up 10, Down 17, A 23, and B 7). The only thing I had to change in the file was to add two lines for Start (which I mapped to pin 8) and Select (which I mapped to pin 11). Here’s what the final retrogame.c file looked like when I was done: http://imgur.com/Y0ZtmT3.

    After I added the rows in nano, I hit Control+X to exit, then answered “Yes” to “Save modified buffer?”, then pressed Enter when it asked “File Name to write: retrogame.c”. Then I got back to the terminal and while the prompt said “pi@raspberrypi ~/retrogame $ ” I typed in “make retrogame” and pressed Enter (all per the Adafruit tutorial). The following line then comes up: “make: “retrogame” is up to date.”

    All the inputs from the Game Boy worked in Retropie after this except for Start and Select. I rechecked everything else (connections to the GPIO pins, solder points on the board, etc.) and everything is correct.

    Can anyone shed any light on why my Start and Select buttons wouldn’t be working? Is anything I’ve done above incorrect, or have I omitted something? Does the line “make: ‘retrogame’ is up to date” reflect a successful make process? I’m a bit of a newbie when it comes to much of this, so any help would be greatly appreciated.

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar