BT Devices (NES30 and FAVI BT keyboard) registered but not working

Home Forums RetroPie Project Controller Configuration in RetroPie BT Devices (NES30 and FAVI BT keyboard) registered but not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of nbk7 nbk7 1 year, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #114029
    Profile photo of hobbswon
    hobbswon
    Participant

    I am a total n00b to linux and I managed to get my install up and running. I used the retroppie config tool from the GUI and registered both my Favi keyboard an NES30 pro.

    The keyboard worked right after I entered the pin. I was aboe to navigate the retropie menus. But after the keyboard went to sleep, when it came back it wouldn’t connect anymore even though it still showed registered.

    Second, I also got the NES30 pro registered and it is running the latest firmware (1.68). But it tue Retroarch config will not detect the gamepad when ES starts. I did find the links for the config files.

    https://github.com/libretro/retroarch-joypad-autoconfig/blob/master/udev/8Bitdo-FC30-1P-GamePad-Bluetooth-Mode%28START%29-Mode%28START%2BR%29.cfg#

    As long as the one for a P2 controller.

    But I have no idea how to implement these configurations. Is it done through command line and/or does it have to be in the linux environment? Is it an edit that can be done on any text editor or in Windows perhaps?

    If someone can point me in the right direction or if there’s any walkthrough…I’d greatly appreciate it. I’m taking some beginners lumps right now.

    #114081
    Profile photo of hobbswon
    hobbswon
    Participant

    I’ve managed to get the nes30 pro to connect initially and mapped to retroarch. But I’ve been racking my brain trying to get the gamepad to reconnect on reboot or when it wakes from sleep.

    I’ve added the udev exception so ES can detect it as a gamepad correctly and i’ve made the edit to trust the device so I don’t have to pair it again on reboot. The device will stay registered but just will not connect.

    It did actually connect automatically once on reboot but I could not duplicate it again. I have to go through the whole registration again.

    Also, when I initially connect then map the gamepad to retroarch through ES, I deleted the cfg manually via floobs instructions…then When I go to set the input from retroarch config tool in retropie setup the menu doesn’t give me the option to configure a gamepad/joystick just a keyboard.

    Could someone kindly help? I feel like I’m close but I’m overlooking something.

    • This reply was modified 1 year, 3 months ago by Profile photo of hobbswon hobbswon.
    #114097
    Profile photo of hobbswon
    hobbswon
    Participant

    Ok, so after a long day I was able to get an NES30 Pro, FC30 Pro and a Favi BT keyboard paired and autoconnecting on reboot. ,

    I had to do a fresh install of Rpi 3.3.1 and follow the tutorial on YouTube from Floob.

    The main issue I am having now is the keyboard, when it falls asleep it will not reconnect when woken up. I have to do a reboot. The gamepads do not have this issue as once they are paired and ES is running..they will not fall asleep. But the keyboard will sleep in a very short time.

    I remember where somebody listed a script or shell to keep the pi2 scanning for the devices but I cannot find it for the life of me. Anyone?

    #114315
    Profile photo of nbk7
    nbk7
    Participant

    I wrote a script for the automatic reconnect:

    http://forum.8bitdo.com/thread-328-7-1.html

    should also work for the pro version

    #114329
    Profile photo of hobbswon
    hobbswon
    Participant

    I wrote a script for the automatic reconnect:

    http://forum.8bitdo.com/thread-328-7-1.html

    should also work for the pro version

    if [ “$(hcitool con)” != *”61:04:00:63:71:01″* ]
    then
    sudo bluez-test-input connect 61:04:00:63:71:01
    fi

    Is that the script? I will add this and try

    #114428
    Profile photo of nbk7
    nbk7
    Participant

    no its in #64

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar