Bluetooth pairing issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 1 year, 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #106905
    Profile photo of jbfortune
    jbfortune
    Participant

    Hey,
    When following this guide
    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller%5B1%5D
    I get to the bit where I scan for the device. It finds it and then when I type sudo bluez-simple-agent hci0 XX:XX:XX:XX:XX:XX changing the xx’s to the mac address of the device. I get the below error.

    /usr/bin/bluez-simple-agent: 4: /usr/bin/bluez-simple-agent: import: not found
    /usr/bin/bluez-simple-agent: 6: /usr/bin/bluez-simple-agent: import: not found
    /usr/bin/bluez-simple-agent: 7: /usr/bin/bluez-simple-agent: import: not found
    /usr/bin/bluez-simple-agent: 8: /usr/bin/bluez-simple-agent: import: not found
    /usr/bin/bluez-simple-agent: 9: /usr/bin/bluez-simple-agent: import: not found
    from: can't read /var/mail/optparse
    /usr/bin/bluez-simple-agent: 12: /usr/bin/bluez-simple-agent: Syntax error: "(" unexpected

    Any ideas?

    Thanks

    #106907
    Profile photo of buzz
    buzz
    Keymaster

    Did you edit the file? – I think you may have broken it. That guide could be improved as there is no need to edit the file but instead the parameter -c DisplayYesNo should be added. I would apt-get remove

    remove and reinstall perhaps.

    
    sudo apt-get remove bluetooth bluez bluez-utils
    sudo apt-get install bluetooth bluez bluez-utils
    
    #106913
    Profile photo of Floob
    Floob
    Moderator

    @jbfortune
    I’ve edited this page to try and make that more clear now
    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller

    As Buzz says, you have most likely made a small error when editing the file, so try the command line version to avoid needing to edit the file at all.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    • This reply was modified 1 year, 7 months ago by Profile photo of Floob Floob.
    #106936
    Profile photo of jbfortune
    jbfortune
    Participant

    Hey guys, thanks for the advice.

    I did in fact edit the file. Because I was inpatient I actually started my image again and tried the BT stuff first and it worked fine this time with me editing the file as the guide said! So maybe I added something in there in error on my original go, pretty unsure to be honest!

    I’m probably going to start again tonight anyway and I will do it without editing the file at all!

    Whilst I have you both in here as well, to save creating another thread. Last time I did my image, within retropie_setup.sh. My Setup / Configuration menu option had more things in to choose. Specifically the option to install Joypad configs. This isn’t in my current version and I have done everything I thought I did last time!

    Could you let me know how I get this updated?

    Last note, Floob, I have watched loads of your YT vids over the last few days, so thanks for them! I’m having fun doing this.

    #106964
    Profile photo of jbfortune
    jbfortune
    Participant

    Little update, using the new command sudo bluez-simple-agent -c DisplayYesNo hci0 then my mac address doesn’t seem to work. Just sticks on the screen for ages!

    #106972
    Profile photo of jbfortune
    jbfortune
    Participant

    Ok, just me being dumb. Seems the Nes30 has several different mac addresses based off what mode its in. I was using Notepad to save typing out all the time and had the wrong Mac address in.

    One thing I have noticed is, if I reboot and turn the pad on, it connects fine. If I shut down the pad whilst in Emu station and try to reconnect, it wont. It’s like auto connect only wants to work once.

    #106973
    Profile photo of Floob
    Floob
    Moderator

    One thing I have noticed is, if I reboot and turn the pad on, it connects fine. If I shut down the pad whilst in Emu station and try to reconnect, it wont. It’s like auto connect only wants to work once.

    Thats right, the steps on the wiki force a connect attempt at start up. If you want it to re-connect after that you would need some sort of cron job, or manually process the command again. Actually you could hook up a script to the retropie menu in ES to do that.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar