Bluetooth Dongle refuses to work on Pi 2 RetroPie 3.0 but works on Pi 1 version

Home Forums RetroPie Project Controller Configuration in RetroPie Bluetooth Dongle refuses to work on Pi 2 RetroPie 3.0 but works on Pi 1 version

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of retrovortex retrovortex 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #102271
    Profile photo of retrovortex

    Hi there.
    I just wanted to quickly talk about the issue I’m having with my Pi 2.
    Basically I upgraded my Pi 1 version of RetroPie to the latest version and then used it for a while in my Pi2. (The emulation performance was obviously worse than the Pi 2 image)
    My Belkin Bluetooth adapter worked brilliantly. Connected PS3 controllers to it straight away. Could use two ps3 controllers simultaneously with zero issues.

    However, when I flashed the Rpi 2’s version onto a new card and started using that, (better performing emulators of course!), and tried setting up my PS3 controllers it would just refuse to connect no matter what I tried.
    I’ve followed the video guide by floob AND I’ve tried the other bluetooth software suggested on this forum. No dice.
    What is interesting though, is that the device is still picked up by the Pi when you run Hciconfig. But somehow it doesn’t seem to register the master MAC address to the controllers properly.

    So say my dongle’s MAC address is:

    What my controller ends up having is:

    Even though it says it’s set it up right when I run sudo ./sixpair

    Likewise when I run the bluez software after setting it up I get a loop of:
    [SIGNAL] org.bluez.Adapter.DeviceCreated
    [SIGNAL] org.bluez.Adapter.PropertyChanged
    [SIGNAL] org.bluez.Device.PropertyChanged
    [SIGNAL] org.bluez.Adapter.PropertyChanged
    [SIGNAL] org.bluez.Adapter.PropertyChanged
    [SIGNAL] org.bluez.Device.PropertyChanged
    [SIGNAL] org.bluez.Adapter.PropertyChanged
    [SIGNAL] org.bluez.Adapter.DeviceRemoved

    Somewhere between the two versions something has changed that is preventing my Belkin adapter to work.
    Do I need to get a new bluetooth device that works with the Pi2’s version of RetroPie? Or is there a way to get the Pi 1’s way of handling it working on the Pi 2 image?

    I feel like I’m going crazy.

    EDIT: This is the Belkin adapter I have:

    • This topic was modified 1 year, 9 months ago by Profile photo of retrovortex retrovortex.

    Profile photo of robertybob

    I don’t have any answers, but I’m sorry to hear it’s stopped working. You’ve dug deeper into your issue that I’m sure most would have, so perhaps open an Issue ticket on the RP Github page if you have no luck getting answer here?

    Profile photo of retrovortex

    That’s a good idea I may do that.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar